[Prophet] [PATCH] sqlite: Fix pragma name: s/default_synchronous/synchronous/

Jesse Vincent jesse at bestpractical.com
Sun Oct 3 22:44:25 EDT 2010


Thanks. Applied.

On Sat 11.Sep'10 at 12:02:32 +0200, Cyril Brulebois wrote:
> The default_synchronous pragma was removed in 2004 according to the
> timeline available on http://www.sqlite.org/, let's use synchronous
> instead. See http://www.sqlite.org/pragma.html for sqlite pragmas.
> 
> Reminder: Setting it to OFF instead of the default FULL makes Jesse
> cry a bit (see eb27c05e52385e059e3a8a679dacea4057c20873), but gives
> a huge perf boost.
> ---
>  lib/Prophet/Replica/sqlite.pm |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/lib/Prophet/Replica/sqlite.pm b/lib/Prophet/Replica/sqlite.pm
> index 256fc3f..6a82c7b 100644
> --- a/lib/Prophet/Replica/sqlite.pm
> +++ b/lib/Prophet/Replica/sqlite.pm
> @@ -29,7 +29,7 @@ has dbh => (
>                  undef, undef,
>                  { RaiseError => 1, AutoCommit => 1 },
>              );
> -            $dbh->do("PRAGMA default_synchronous = OFF");
> +            $dbh->do("PRAGMA synchronous = OFF");
>          };
>          if ($@) {
>              die "Unable to open the database file '".$self->db_file
> -- 
> 1.7.1
> 
> _______________________________________________
> Prophet mailing list
> Prophet at bestpractical.com
> http://lists.bestpractical.com/cgi-bin/mailman/listinfo/prophet


More information about the Prophet mailing list