[Rt-commit] rtir branch, 3.4/countermeasures, repushed

Shawn Moore shawn at bestpractical.com
Fri May 20 15:17:01 EDT 2016


The branch 3.4/countermeasures was deleted and repushed:
       was eff388935c7669af7c494e3a572c23fef85104c1
       now 58773ee64b6dba315687fe46db1df579ad8eb904

 1:  af89baa =  1:  af89baa Use RT::IR->lifecycle_* methods instead of hardcoding
 2:  43b776b =  2:  43b776b Rename lifecycle from "blocks" to "countermeasures"
 3:  383bb5e =  3:  383bb5e Switch lifecycle definition from "blocks" to "countermeasures"
 4:  36b5bc5 =  4:  36b5bc5 Switch default queue from Blocks to Countermeasures
 5:  8c7de77 =  5:  8c7de77 Rename Blocks menu at top to Countermeasures
 6:  99ef2bf =  6:  99ef2bf Switch %TYPE to use lifecycle methods (and Countermeasures)
 7:  af6e5ae =  7:  af6e5ae Fix error to mention plural Countermeasure queues rather than Block queue
 8:  287b968 =  8:  287b968 Rename SelectedBlocks to SelectedCountermeasures
 9:  b97f165 =  9:  b97f165 Fix one instance of hardcoded name Blocks in UI to be Countermeasure
10:  1073c9b = 10:  1073c9b Rename create_block and goto_edit_block test functions
11:  a35a885 = 11:  a35a885 Switch hardcoded "Blocks" queue name in tests to "Countermeasures"
12:  2b52712 = 12:  2b52712 Fix some references in RTIR_Config to Countermeasures
13:  f09061f = 13:  f09061f Rename RTIR_DisableBlocksQueue to RTIR_DisableCountermeasures
14:  d1478c8 = 14:  d1478c8 Fix the tab name from blocks to countermeasures
15:  60d0745 = 15:  60d0745 Change blocks to countermeasures in comments and internal documentation
16:  a512a21 = 16:  a512a21 Fix references to Blocks in README
17:  835c539 = 17:  835c539 Update documentation to refer to Countermeasures not Blocks
18:  87b40a0 = 18:  87b40a0 Fix some CSS class names to match 3.4 spelling
19:  fdc75b4 = 19:  fdc75b4 Fix stray references of blocks to be countermeasures
20:  ce554cf = 20:  ce554cf Fix uses of block with countermeasure in t/searches/menu.t
21:  bb8fa78 = 21:  bb8fa78 Fix test filenames to be countermeasure/ not block/
22:  f108563 = 22:  f108563 Rename RTIR_SetBlockStatus to RTIR_SetCountermeasureStatus
23:  0ac4c7a = 23:  0ac4c7a Rename $RTIR_BlockAproveActionRegexp to $RTIR_CountermeasureApproveActionRegexp
24:  cbad054 = 24:  cbad054 MANIFEST update for t/block -> t/countermeasure
25:  575bc45 = 25:  575bc45 Rename BlockRemoved template to CountermeasureRemoved
26:  78b96a1 = 26:  78b96a1 Finish renaming "set block status" to countermeasure
27:  ab2b15e = 27:  ab2b15e Rename EveryoneBlockRights to EveryoneCountermeasureRights
28:  6cdb8d0 = 28:  6cdb8d0 Fix names of search result format keys to countermeasure
29:  09c9904 = 29:  09c9904 Upgrade old "blocks" lifecycles to countermeasures
30:  f888baa = 30:  f888baa Bail out if unable to load the "base" queue in add_constituency
31:  34f7966 = 31:  34f7966 Load base lifecycle queue by finding the queue with lowest ID
32:  154238b = 32:  154238b Fix queues to be named Countermeasures
33:  6fb2227 = 33:  6fb2227 Switch Blocks to Countermeasures for CF descriptions
34:  73e6e5d = 34:  73e6e5d Break up constituency and countermeasures upgrades
35:  39c6332 = 35:  39c6332 Fix mis-set constituency-queue lifecycles _before_ constituency upgrade
36:  208ce1e = 36:  208ce1e Have 3.3.2 and 3.3.4 upgrade scripts use Countermeasures not Blocks
37:  9f0254f = 37:  9f0254f UPGRADING-3.4 doc for Countermeasures
38:  eff3889 ! 38:  58773ee Fix scrips and templates that use blocks
    @@ -23,25 +23,34 @@
     +        {
     +            my $action = RT::ScripAction->new(RT->SystemUser);
     +            $action->Load('RTIR Set Block Status');
    -+            $action->Set(Field => 'Name', Value => 'RTIR Set Countermeasure Status');
    -+            $action->Set(Field => 'ExecModule', Value => 'RTIR_SetCountermeasureStatus');
    ++
    ++            my ($ok, $msg) = $action->SetName('RTIR Set Countermeasure Status');
    ++            RT->Logger->error($msg) if !$ok;
    ++
    ++            ($ok, $msg) = $action->SetDescription('Set the status of a Countermeasure');
    ++            RT->Logger->error($msg) if !$ok;
    ++
    ++            ($ok, $msg) = $action->SetExecModule('RTIR_SetCountermeasureStatus');
    ++            RT->Logger->error($msg) if !$ok;
     +        }
     +
     +        # fix BlockRemoved templates
     +        {
     +            my $templates = RT::Templates->new(RT->SystemUser);
    -+            $templates->Limit(FIELD => 'Name', Value => 'BlockRemoved');
    ++            $templates->Limit(FIELD => 'Name', VALUE => 'BlockRemoved');
     +            while (my $template = $templates->Next) {
    -+                $template->SetName('CountermeasureRemoved');
    ++                my ($ok, $msg) = $template->SetName('CountermeasureRemoved');
    ++                RT->Logger->error($msg) if !$ok;
     +            }
     +        }
     +
     +        # fix scrips that use BlockRemoved
     +        {
     +            my $scrips = RT::Scrips->new(RT->SystemUser);
    -+            $scrips->Limit(FIELD => 'Template', Value => 'BlockRemoved');
    ++            $scrips->Limit(FIELD => 'Template', VALUE => 'BlockRemoved');
     +            while (my $scrip = $scrips->Next) {
    -+                $scrip->SetTemplate('CountermeasureRemoved');
    ++                my ($ok, $msg) = $scrip->SetTemplate('CountermeasureRemoved');
    ++                RT->Logger->error($msg) if !$ok;
     +            }
     +        }
          },



More information about the rt-commit mailing list