[rt-users] Mail setup problems

Cory Capone CCapone at consultdove.com
Thu Jun 27 13:59:00 EDT 2002


I did run the following command:
ln -s /path/to/rt2/bin/rt-mailgate /etc/smrsh/rt-mailgate
I assume that's what you mean by "you enabled the rt-mailgate program
permission to allow sendmail to execute it?"

Mail doesn't bounce back with any errors, unfortunately - I think it'd be easier if it did!

One thing that may be of use (or not):
I tried "running" rt-mailgate and it just seems to hang.  The reason for the quotes is that all I did
was type "./rt-mailgate".  I wasn't sure if that was the proper way to do it or not, so I also tried "perl rt-mailgate".
Both just seem to hang.  I tried "perl -c rt-mailgate" and it said the syntax was fine.

Anyways, that probably isn't of use, but I dunno.

Thanks again for helping!
Cory

> The machine's name is "it-dove.com"
> and I can send mail to root at it-dove.com just fine.
> the queue name is HelpDesk
> and my aliases are set up as follows:
>
> support: "|/opt/rt2/bin/rt-mailgate --queue HelpDesk --action correspond"
> support-comment: "|/opt/rt2/bin/rt-mailgate --queue HelpDesk --action
comment"
>
> After trying to send an email to support at it-dove.com, nothing happens and
I get the following in the sendmail log:
> Jun 27 10:03:57 it-dove sendmail[2339]: g5RE3vr02339:
from=<CCapone at consultdove.com>, size=633, class=0, nrcpts=1,
msgid=<6044748DB501154CA7821B832E2238B94A8289 at mail.doveassoc.com>,
proto=ESMTP, daemon=Daemon0, relay=mail.doveassoc.com [10.1.0.222]
> Jun 27 10:03:59 it-dove sendmail[2340]: g5RE3vr02339:
to="|/opt/rt2/bin/rt-mailgate --queue HelpDesk --action correspond",
ctladdr=<support at it-dove.com> (8/0), delay=00:00:02, xdelay=00:00:02,
mailer=prog, pri=30105, dsn=5.3.0, stat=unknown mailer error 2
> Jun 27 10:03:59 it-dove sendmail[2340]: g5RE3vr02339: g5RE3xr02340: DSN:
unknown mailer error 2
> Jun 27 10:03:59 it-dove sendmail[2340]: g5RE3xr02340:
to=<CCapone at consultdove.com>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp,
pri=30205, relay=jeeves.doveassoc.com. [10.1.0.216], dsn=2.0.0, stat=Sent
( <200206271403.g5RE3xr02340 at it-dove.com> Queued mail for delivery)

Just a quick thought, but have you enabled the rt-mailgate program
permission to allow sendmail to execute it?
Hang on...
Mine lives here:

lrwxrwxrwx   1 root     root           25 Jun 12 02:57
/usr/adm/sm.bin/rt-mailgate -> /home/rt2/bin/rt-mailgate

The permissions might be wrong, but that's the general idea.
I don't know if this is a cobalt thing, or a sendmail thing, since it's been
a while since I used sendmail. Qmail much nicer, but I got it working.
Does it bounce mail back to you with any errors?

It looks like it's sendind something back to jeeves for you, perhaps?
Cool name, by the way.
Let me know, I might have some other ideas.






More information about the RT-Users mailing list