[rt-users] RT 4.2 Segfaults on FreeBSD 9.2

Rainer Duffner rainer at ultra-secure.de
Wed Dec 18 19:04:26 EST 2013


Am 19.12.2013 um 01:00 schrieb Tim Gustafson <tjg at ucsc.edu>:

>> So, it’s a jail.
> 
> Yes, sorry, I forgot to mention that.
> 
>> Did you actually install perl?
> 
> Of course, it's a dependency of RT:
> 
> root at rt-dev.soe.ucsc.edu: pkg_info |grep ^perl
> perl5-5.16.3_4      Practical Extraction and Report Language
> 
>> But it’s OK, if reproducibility is not an issue.
> 
> For what it's worth, I originally tried to do this as an upgrade from
> 4.0.16 to 4.2, but that failed with this same error, so I uninstalled
> Perl, and all its dependencies, removed everything from /var/db/ports/
> to make sure that all the default options were used while building,
> and then re-installed 4.2.
> 
> If it helps, I can kill the whole jail and install a totally clean one
> and then try again.
> 


That is really strange.
I recently did a test-install (of 4.0.x) - with packages from my own repository (which is unfortunately not public) and that did work.
Didn’t get around trying 4.2 yet.

Do you actually have a 5.18 site_perl directory?





More information about the rt-users mailing list