[rt-users] Setup RT-Mailgate

Bryon Baker bbaker at copesan.com
Mon Jul 1 12:26:07 EDT 2013


I am getting the following message when getting mail.
delivered to MDA_external command rt-mailgate ()
I cannot find any new tickets.


I do not appear to have connect messages in the apache logs.  What do I need to check next?

Here is my get mail log
Getmail config 
[retriever]
type = SimpleIMAPSSLRetriever
server = imap.gmail.com
port = 993
username = testxxxxxx at gmail.com
password = xxxxxxxxxx
mailboxes = ('INBOX',)

[destination]
type = MDA_external
path = /usr/bin/rt-mailgate
user = rtuser
group = rtgroup
arguments = ("--url", "http://localhost/rt", "--queue", "IT Support", "--action", "correspond",)

[options]
read_all = false
delete = false
received = false
delivered_to = false
message_log = /var/log/request-tracker/mvmail.log


Thanks
Bryon Baker
Network Operations Manager
Copesan - Specialists in Pest Solutions
800-267-3726  .  262-783-6261 ext. 2296
bbaker at copesan.com
www.copesan.com
"Servicing North America with Local Care"


-----Original Message-----
From: rt-users-bounces at lists.bestpractical.com [mailto:rt-users-bounces at lists.bestpractical.com] On Behalf Of Kevin Falcone
Sent: Monday, July 01, 2013 11:12 AM
To: rt-users at lists.bestpractical.com
Subject: Re: [rt-users] Setup RT-Mailgate

On Fri, Jun 28, 2013 at 09:57:56PM +0000, Bryon Baker wrote:
>    I figured out the issue.  All I have to do is run the program from the tmp directory.
> 
>    I now get the following message
> 
>    delivered to MDA_external command rt-mailgate ()
> 
>    But can't find it in RT no ticket created.
> 

I don't see where you specified what I assume is your fetchmail configuration to run rt-mailgate?

You should also be reading your Apache logs to make sure that rt-mailgate is actually connecting to RT.

-kevin



More information about the rt-users mailing list