[rt-users] RT not sending outgoing emails

Darin Perusich darin at darins.net
Fri Nov 7 15:10:13 EST 2014


Are you running postfix in a chroot? If so perhaps the chroot needs to
be updated.
--
Later,
Darin


On Fri, Nov 7, 2014 at 1:48 PM,  <livy at fhsu.edu> wrote:
> Hello All,
>
> I'm having a weird problem where RT can't send out going emails.  I'm using
> Postfix and running sendmail command from the shell works fine, just
> whenever a new ticket gets created or a comment was added, RT is not able to
> send outgoing emails.
>
> On the web interface, it says:
> The RT System itself - Sending the previous mail has failed. Please contact
> your admin, they can find more details in the logs.
>
> In syslogs, the following error is thrown:
> Nov  7 09:04:30 *** postfix/sendmail[30696]: fatal: file
> /etc/postfix/main.cf: parameter setgid_group: unknown group name: postdrop
>
> At first I thought a misconfigured postfix is causing the problem, but again
> I can run sendmail command from the shell and it sends out email with no
> problem.
>
> I do have the postdrop group in  my /etc/group file.
>
> What's weird is there is no "setgid_group" in file /etc/postfix/main.cf.
>
> Below is output of postconf -n:
>
> alias_database = hash:/etc/aliases
> alias_maps = hash:/etc/aliases
> append_dot_mydomain = no
> biff = no
> config_directory = /etc/postfix
> inet_interfaces = all
> inet_protocols = ipv4
> mailbox_size_limit = 0
> mydestination = [domain], [domain], localhost
> myhostname = [domain]
> mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
> myorigin = /etc/mailname
> readme_directory = no
> recipient_delimiter = +
> relayhost = [some ip]
> smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
> smtpd_banner = $myhostname ESMTP I.T., have you tried turning it off and on
> again?
> smtpd_client_restrictions = reject_rbl_client bl.spamcop.net,
> reject_unauth_pipelining, permit
> smtpd_data_restrictions = reject_unauth_pipelining, permit
> smtpd_helo_required = yes
> smtpd_helo_restrictions = reject_invalid_helo_hostname,
> reject_non_fqdn_helo_hostname, reject_unauth_pipelining, permit
> smtpd_recipient_restrictions = reject_non_fqdn_recipient,
> reject_unknown_recipient_domain, reject_unauth_destination,
> reject_unauth_pipelining, permit_auth_destination, permit_mynetworks
> smtpd_timeout = 30s
> smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
> smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
> smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
> smtpd_use_tls = yes
>
>
> I'm running RT 4.2.8 on a Debian Wheezy box with MySQL server.   Anyone has
> any insight to my problem?   Any suggestions is greatly appreciated!
>
> Livy


More information about the rt-users mailing list