[rt-users] RT 4.4.0 Apache loads text of rt-server fcgi rather than login

Brad bradzynda42 at comcast.net
Sun Feb 21 12:20:28 EST 2016


Hi All,

Set it up as Piotr pointed out but now getting an Internal error:

[Sun Feb 21 16:51:48.198523 2016] [mpm_prefork:notice] [pid 32464]
AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips mod_fcgid/2.3.9
PHP/5.4.16 mod_perl/2.0.9dev Perl/v5.16.3 configured -- resuming normal
operations


Can't locate UNIVERSAL/require.pm in @INC (@INC contains:
/opt/rt4/sbin/../local/lib /opt/rt4/sbin/../lib /usr/local/lib64/perl5
/usr/local/share/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
/opt/rt4/sbin/../lib/RT.pm line 60.
BEGIN failed--compilation aborted at/opt/rt4/sbin/../lib/RT.pm line 60.
Compilation failed in require at /opt/rt4/sbin/rt-server.fcgi line 86.


  From browser:
500 Internal Server Error

The server encountered an internal error or misconfiguration and was
unable to complete your request.

Please contact the server administrator at <our email> to
inform them of the time this error occurred, and the actions you
performed just before this error.

More information about this error may be available in the server error log.

Then I see the at the bottom of the logs:

mod_fcgid: error reading data from FastCGI server

core:error End of script output before headers: rt-server.fcgi


At this point do I need to re-install with a different configure 
--with-web-handler=fcgid instead of --with-web-handler=fastcgi ?

Thanks,
Brad

On 02/19/2016 01:47 PM, Brad wrote:
> Hi Piotr,
>
> Ahhh
>
> did a yum search for fastcgi and thats what was available, didnt even 
> look that closely at the mod name.
>
> Thanks,
> Brad
>
> On 02/19/2016 01:25 PM, Piotr Szymborski wrote:
>> Hi Brad,
>>
>> for starters mod_fastcgi is not the same as mod_fcgid, you need to 
>> configure it differently.
>> Look on 
>> https://www.bestpractical.com/docs/rt/4.4/web_deployment.html#mod_fcgid 
>> vs 
>> https://www.bestpractical.com/docs/rt/4.4/web_deployment.html#mod_fastcgi
>> Just ctrl+c,ctrl+v that code to your apache config, modify directory 
>> to rt if it differs and it should work using mod_fcgid.
>>
>> Best regards,
>> Piotr Szymborski
>>
>> On 2016-02-19 18:49, Brad wrote:
>>> Hi Matt,
>>>
>>> yum install mod_fcgid
>>> Loaded plugins: fastestmirror, rhnplugin
>>> This system is receiving updates from RHN Classic or Red Hat Satellite.
>>> Loading mirror speeds from cached hostfile
>>> Package mod_fcgid-2.3.9-4.el7.x86_64 already installed and latest 
>>> version
>>> Nothing to do
>>>
>>>
>>> added to siteconf:
>>>
>>> FastCgiServer /opt/rt4/sbin/rt-server.fcgi -processes 5 
>>> -idle-timeout 300
>>>
>>>
>>> restarted httpd and it errors:
>>>
>>>
>>> Invalid command 'FastCgiServer', perhaps misspelled or defined by a
>>> module not included in the server configuration
>>>
>>>
>>>
>>> Now I dont see any reference for where yum puts this but a locate 
>>> pulls:
>>> /usr/lib/tmpfiles.d/mod_fcgid.conf
>>> /usr/lib64/httpd/modules/mod_fcgid.so
>>> /usr/share/doc/mod_fcgid-2.3.9
>>> /usr/share/doc/mod_fcgid-2.3.9/CHANGES-FCGID
>>> /usr/share/doc/mod_fcgid-2.3.9/ChangeLog
>>> /usr/share/doc/mod_fcgid-2.3.9/LICENSE-FCGID
>>> /usr/share/doc/mod_fcgid-2.3.9/NOTICE-FCGID
>>> /usr/share/doc/mod_fcgid-2.3.9/README-FCGID
>>> /usr/share/doc/mod_fcgid-2.3.9/STATUS-FCGID
>>> /usr/share/doc/mod_fcgid-2.3.9/fixconf.sed
>>> /usr/share/doc/mod_fcgid-2.3.9/mod_fcgid.html.en
>>>
>>>
>>> I do see some directions fromwww.fastcgi.com/mod_fastcgi/INSTALL for a
>>> binary build but nothing in reference to a package install but this 
>>> does
>>> look correct, doesn't it?
>>>
>>> /usr/lib64/httpd/modules/mod_fcgid.so
>>>
>>> and the new httpd grabs these on start...?
>>>
>>>
>>>
>>> Thanks,
>>> Brad
>>>
>>>
>>>
>>> On 02/19/2016 12:23 PM, Matt Zagrabelny wrote:
>>>> On Fri, Feb 19, 2016 at 11:18 AM, Brad <bradzynda42 at comcast.net> 
>>>> wrote:
>>>>> Hi Matt,
>>>>>
>>>>> I did follow a guide not sure if it was the most recent or the one 
>>>>> required
>>>>> by RT though, used apache.org I think.
>>>> https://www.bestpractical.com/docs/rt/4.4/web_deployment.html#mod_fastcgi 
>>>>
>>>>
>>>>> Here is the siteconf, the httpd.conf and ssl.conf are base (not 
>>>>> edited,
>>>>> except for servername and cipher suite)
>>>> The docs have a line like:
>>>>
>>>> FastCgiServer /opt/rt4/sbin/rt-server.fcgi -processes 5 
>>>> -idle-timeout 300
>>>>
>>>>> <VirtualHost xxx.xxx.xxx.xxx:443>
>>>>> ServerName <our FQDN>
>>>>>
>>>>> LoadModule fcgid_module modules/mod_fcgid.so
>>>>>
>>>>> SSLCertificateFile /etc/pki/tls/certs/ca.crt
>>>>> SSLCertificateKeyFile /etc/pki/tls/private/ca.key
>>>>>
>>>>> AddDefaultCharset UTF-8
>>>>>
>>>>>           ScriptAlias /rt /opt/rt4/sbin/rt-server.fcgi
>>>> The docs have a trailing slash on rt-server.fcgi. Not sure if that 
>>>> matters.
>>>>
>>>> -m
>>>>
>>>
>>> ---------
>>> RT 4.4 and RTIR Training Sessions 
>>> (http://bestpractical.com/services/training.html)
>>> * Hamburg Germany - March 14 & 15, 2016
>>> * Washington DC - May 23 & 24, 2016
>>>
>>
>>
>
> ---------
> RT 4.4 and RTIR Training Sessions 
> (http://bestpractical.com/services/training.html)
> * Hamburg Germany - March 14 & 15, 2016
> * Washington DC - May 23 & 24, 2016
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20160221/770d6411/attachment.html>


More information about the rt-users mailing list