[Rtir] RT 4.x status

Marco Thorbruegge marco.thorbruegge at cert.europa.eu
Tue Mar 13 12:20:04 EDT 2012


tried an upgrade to RT 4.0.5 and RTIR 3.0.0 RC1 on a test system.

Starting position: installed up and running (on Ubuntu, add a 'sudo'
before all commands)

RT 3.8.10
RTIR 2.6.1
RTFM 2.4.3

(with a rather small DB, only few incidents, nothing complicated).

Location /opt/rt3/

1) Upgrade to RT 4.0.5

worked well as described in the README, via 'make fixdeps' and 'make

Installation into a new folder /opt/rt4/

2) Database configuration

started the standalone server, configured a few things. initialisation
worked fine.

Stopped the standalone server

3) Here's where it stops me right now: Database upgrade

make upgrade-database


ubuntu at rt4:~/install/rt-4.0.5$ sudo make upgrade-database
/usr/bin/perl -I/opt/rt4/local/lib -I/opt/rt4/lib sbin/rt-setup-database
--action upgrade --prompt-for-dba-password
In order to create or update your RT database, this script needs to
connect to your  mysql instance on localhost as root
Please specify that user's database password below. If the user has no
password, just press return.

Working with:
Type:	mysql
Host:	localhost
Name:	rt4
User:	rt_user
DBA:	root
Enter RT version you're upgrading from: 3.8.10

Going to apply following upgrades:
* 3.9.1
* 3.9.2
* 3.9.3
* 3.9.5
* 3.9.6
* 3.9.7
* 3.9.8
* 4.0.0rc2
* 4.0.0rc4
* 4.0.0rc7
* 4.0.1
* 4.0.3
* 4.0.4

Enter RT version if you want to stop upgrade at some point,
  or leave it blank if you want apply above upgrades: <blank>


Proceed [y/N]: y

Processing 3.9.1
Now inserting data.
Processing 3.9.2
Now inserting data.
[Tue Mar 13 17:06:47 2012] [warning]: DBD::mysql::st execute failed:
Unknown column 'main.DelegatedBy' in 'where clause' at
/usr/local/share/perl/5.10.1/DBIx/SearchBuilder/Handle.pm line 587, <>
line 1. (/usr/local/share/perl/5.10.1/DBIx/SearchBuilder/Handle.pm:587)
[Tue Mar 13 17:06:47 2012] [warning]: RT::Handle=HASH(0x4aa1638)
couldn't execute the query 'SELECT main.* FROM ACL main  WHERE
(main.DelegatedBy > '0') AND (main.DelegatedFrom > '0') ' at
/usr/local/share/perl/5.10.1/DBIx/SearchBuilder/Handle.pm line 600
'SELECT main.* FROM ACL main  WHERE (main.DelegatedBy > \'0\')...')
called at /usr/local/share/perl/5.10.1/DBIx/SearchBuilder.pm line 235
	DBIx::SearchBuilder::_DoSearch('RT::ACL=HASH(0x6870250)') called at
/home/ubuntu/install/rt-4.0.5/sbin/../lib/RT/SearchBuilder.pm line 320
	RT::SearchBuilder::_DoSearch('RT::ACL=HASH(0x6870250)') called at
/home/ubuntu/install/rt-4.0.5/sbin/../lib/RT/ACL.pm line 260
	RT::ACL::_DoSearch('RT::ACL=HASH(0x6870250)') called at
/usr/local/share/perl/5.10.1/DBIx/SearchBuilder.pm line 503
	DBIx::SearchBuilder::Next('RT::ACL=HASH(0x6870250)') called at
/home/ubuntu/install/rt-4.0.5/sbin/../lib/RT/ACL.pm line 225
	RT::ACL::Next('RT::ACL=HASH(0x6870250)') called at
./etc/upgrade/3.9.2/content line 19
	RT::Handle::__ANON__() called at
/home/ubuntu/install/rt-4.0.5/sbin/../lib/RT/Handle.pm line 767
	eval {...} called at
/home/ubuntu/install/rt-4.0.5/sbin/../lib/RT/Handle.pm line 767
'./etc/upgrade/3.9.2/content', undef) called at sbin/rt-setup-database
line 293
	main::action_insert('prompt-for-dba-password', 1, 'datafile', undef,
'action', 'upgrade', 'datadir', './etc/upgrade/3.9.2', 'backcompat',
...) called at sbin/rt-setup-database line 399
	main::action_upgrade('prompt-for-dba-password', 1, 'action', 'upgrade',
'dba', 'root') called at sbin/rt-setup-database line 198
[Tue Mar 13 17:06:47 2012] [crit]: _DoSearch is not so successful as it
still needs redo search, won't call _BuildHash
Processing 3.9.3
Now populating database schema.
[Tue Mar 13 17:06:47 2012] [crit]: DBD::mysql::st execute failed: Can't
DROP 'DelegatedBy'; check that column/key exists at
/home/ubuntu/install/rt-4.0.5/sbin/../lib/RT/Handle.pm line 517.
DBD::mysql::st execute failed: Can't DROP 'DelegatedBy'; check that
column/key exists at
/home/ubuntu/install/rt-4.0.5/sbin/../lib/RT/Handle.pm line 517.
make: *** [upgrade-database] Error 255


Any hint appreciated!

(Obviously i did not yet start to apply RTIR 3.0.0 RC1.)

Many thanks!

Best regards,

BTW: In my frustration i did a new install of RT 4.0.5 and RTIR 3.0.0
RC1. I did a "make initialise-database" and then imported a recent dump
from RT3.8.10/RTIR2.6.1 into the RT4 database (cat rt3-dump.sql | mysql
-u root -p rt4).

It seems to work for many things, but not for all (lookup of IP-adresses
only partial works for example.)

More information about the Rtir mailing list