[Pushmi-users] Please, I need help...Authentication issues

Leif Canfield leif.canfield at adayana.com
Mon Mar 3 13:44:42 EST 2008

Hi I need some help getting pushmi to work.  I want to sync two repositories...if I can get it to work one will be in India, but for simplicity I'm testing on two local machines.  I have SVN set up for LDAP authentication (Active Directory) and to run through apache, the developers are all used to Tortoise.  I'm running Debian Etch and I installed Pushmi using David Bremner's apt package.  I was able to mirror the repositories successfully, but when I try to commit any changes I get this error:
   MERGE request failed on '/tstrepo'
   'pre-commit' hook failed with error output:
   Authorization failed: OPTIONS request failed on '/tstrepo': OPTIONS of
   '/tstrepo': authorization failed (http://other.repo.com) at
   /usr/share/perl5/SVK/Mirror/Backend/SVNRa.pm line 631


username: <myLDAPusername>
password: <myLDAPpw>
authproxy_port: 8123     #I'm running memcached on this port as the apache user
used_shared_commit: 1   #tried it with and without this line
use_cached_auth: 1       #tried it with and without this line

Can someone please tell me what I need to do to get this to work?  Once it does work, can users still make commits if the two servers are temporarily unable to communicate (I'm worried about more anchors and internet outages)?

I have Pushmi on both servers, is that the correct way to set it up?

More information about the Pushmi-users mailing list