[rt-devel] Can't locate object method "Load" via package "RT::System"

Rafael Maximo maximo at maximo.br.fm
Thu Nov 14 18:42:09 EST 2002


I tried to search the list archives looking for some similar error but i 
didn't find anything and then a decided to post my problem here.

I tried to install RT 2.1.46 and i got a few problems, the first one was 
when i tried to use "make testdeps" it says that I needed the module 
DBIx::SearchBuilder 0.7 but i cant find the version 0.7 and i'm using the 
version 0.61  and it says too that e needed the module Apache::DBI and i'm 
sure this module is installed i just don't know why it shows as if it 
wasn't installed e even tried to force the instalation via CPAN but it 
still didn't detect

So i tried to install it anyway using make install and i'm also using 
FastCGI, here is my httpd.conf:


<VirtualHost my.server.ip>
ServerName rt.domain.com
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
Alias /NoAuth/images/rt.jpg /opt/rt3/html/NoAuth/images/rt.jpg
Documentroot /opt/rt3/html/


And it works pretty good but after logging in and clicking on "Preferences" 
and then "Delegation Rights" I got this error:

------------------error message-------------
System error

error:  Can't locate object method "Load" via package "RT::System" at 
/opt/rt3/lib/RT/ACE_Overlay.pm line 782.

context:  ...
778:  $appliesto_obj = $self->__Value('ObjectType')->new($self->CurrentUser);
779:  unless (ref( $appliesto_obj) eq $self->__Value('ObjectType')) {
780:  return undef;
781:  }
782:  $appliesto_obj->Load( $self->__Value('ObjectId') );
783:  return ($appliesto_obj);
784:  }
785:  else {
786:  $RT::Logger->warning( "$self -> Object called for an object "

code stack:  /opt/rt3/lib/RT/ACE_Overlay.pm:782


I also tested using mod_perl but i got the same error. Any sugestions? Is 
this a bug?


More information about the Rt-devel mailing list