[Rt-devel] Webmux.pl make Apache2 crash

Francisco Javier Martínez Martinez fjmartinez at csi.uned.es
Wed Dec 1 09:20:54 EST 2004

Hello World.

I am getting crazy with this problem...

I had installed in a Fedora Core 3, Apache2 + MySQL + mod_perl-1.99_16-3

The installation notes:
./configure --prefix=/usr/local/rt3 
--with-db-type=mysql  --with-web-group=nobody --with-web-user=nobody 

perl sbin/rt-test-dependencies --with-mysql --with-modperl2 --install
perl sbin/rt-test-dependencies --with-mysql --with-modperl --install

NOTE: I had desesperatily tried both lines with the same result.

make install
make initialize-database

Everything at this point seems good, the install said that everything goes 
fine, and  before of adding the rt3 config file to the apache, it works 
fine (apache + modperl) but after adding this file to apache conf.d 
directory it is not working:


<VirtualHost IP ADDRESS>
    ServerName xxx.xxxx.es
    DocumentRoot /usr/local/rt3/share/html
    AddDefaultCharset UTF-8

  # these four lines apply to Apache2+mod_perl2 only: {{{     <<< I had 
tried commenting this lines too.
   PerlSetVar MasonArgsMethod CGI
   PerlModule Apache2 Apache::compat
   RewriteEngine On
    RewriteRule ^(.*)/$ $1/index.html
  # }}}

    PerlModule Apache::DBI
    PerlRequire /usr/local/rt3/bin/webmux.pl

    <Location />
        SetHandler perl-script
        PerlHandler RT::Mason

The Httpd start resutls:

/etc/rc.d/init.d/httpd start
Iniciando httpd: [Wed Dec 01 15:10:49 2004] [error] Can't load 
for module MIME::Base64: 
failed to map segment from shared object: Permission denied at 
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm line 230.\n at 
/usr/lib/perl5/site_perl/5.8.5/MIME/Words.pm line 85\nCompilation failed in 
require at /usr/lib/perl5/site_perl/5.8.5/MIME/Words.pm line 85.\nBEGIN 
failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.5/MIME/Words.pm 
line 85.\nCompilation failed in require at 
/usr/lib/perl5/site_perl/5.8.5/MIME/Head.pm line 123.\nBEGIN 
failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.5/MIME/Head.pm 
line 123.\nCompilation failed in require at 
/usr/lib/perl5/site_perl/5.8.5/MIME/Entity.pm line 235.\nBEGIN 
failed--compilation aborted at 
/usr/lib/perl5/site_perl/5.8.5/MIME/Entity.pm line 235.\nCompilation failed 
in require at /usr/local/rt3/lib/RT/I18N.pm line 66.\nBEGIN 
failed--compilation aborted at /usr/local/rt3/lib/RT/I18N.pm line 
66.\nCompilation failed in require at /usr/local/rt3/lib/RT.pm line 
48.\nBEGIN failed--compilation aborted at /usr/local/rt3/lib/RT.pm line 
48.\nCompilation failed in require at /usr/local/rt3/bin/webmux.pl line 
64.\nBEGIN failed--compilation aborted at /usr/local/rt3/bin/webmux.pl line 
64.\nCompilation failed in require at (eval 4) line 1.\n
[Wed Dec 01 15:10:49 2004] [error] Can't load Perl file: 
/usr/local/rt3/bin/webmux.pl for server nerea-seis.uned.es:0, exiting...

I had checked that there is not dependencies installing all required 
modules via CPAN.

Sorry for my English but I had read nearly 100 post looking for that 
problem, with no success..

Thanks in advance.

More information about the Rt-devel mailing list