[Rt-devel] Web login, user and password???

Francisco Javier Martínez Martinez fjmartinez at csi.uned.es
Thu Dec 2 08:21:06 EST 2004


Already I  had installed RT in a Fedora Core 3 Apache 2 + Mod_perl 1.99 + 

Apache starts and I can load the RT login page in my browser, but what is 
the user/pass that I had to put in the box??

I had read in 
http://www.sun.com/bigadmin/features/articles/req_track_2.html that this 
user must be the user setup at configuration time but it seems not to work. 
I put in the login box : User: rt or rt_user or root and his corresponding 
passwrods but nothing happens.

Compilation notes:
./configure --prefix=/usr/local/rt3 
--with-db-type=mysql  --with-rt-group=rt --with-db-dba=root 
--with-db-rt-user=rt_user --with-web-group=nobody --with-web-user=nobody 

perl sbin/rt-test-dependencies --with-mysql --with-modperl2
make install
make initialize-database

Significant parts of my RT_Siteconfig.pm

#The name of the database user (inside the database)
Set($DatabaseUser , 'rt_user');

# Password the DatabaseUser should use to access the database
Set($DatabasePassword , 'xxxx');

# The name of the RT's database on your database server
Set($DatabaseName , 'rt3');

My apache's error_log said:

[Thu Dec  2 13:10:08 2004] [error]: FAILED LOGIN for root from 
62.204.xxx.xx (/usr/local/rt3/share/html/autohandler:196)
[Thu Dec  2 13:10:19 2004] [error]: FAILED LOGIN for rt from 62.204.xxx.xx 

My MySQL said:
mysql> status
/usr/bin/mysql  Ver 12.22 Distrib 4.0.22, for pc-linux (i686)

Connection id:          28
Current database:       rt3
Current user:           rt_user at localhost
SSL:                    Not in use
Current pager:          stdout
Using outfile:          ''
Server version:         4.0.22-standard
Protocol version:       10
Connection:             Localhost via UNIX socket
Client characterset:    latin1
Server characterset:    latin1
UNIX socket:            /var/lib/mysql/mysql.sock
Uptime:                 53 min 37 sec

Threads: 9  Questions: 746  Slow queries: 0  Opens: 146  Flush tables: 
1  Open tables: 22  Queries per second avg: 0.232

Thanks in advance.

At 16:45 01/12/2004, Ruslan U. Zakirov wrote:
>Francisco Javier Martínez Martinez wrote:
>>Hello World.
>>I am getting crazy with this problem...
>>I had installed in a Fedora Core 3, Apache2 + MySQL + mod_perl-1.99_16-3
>>The installation notes:
>>./configure --prefix=/usr/local/rt3 --with-db-type=mysql
>>--with-web-group=nobody --with-web-user=nobody --with-db-rt-pass=xxx
>>perl sbin/rt-test-dependencies --with-mysql --with-modperl2 --install
>>perl sbin/rt-test-dependencies --with-mysql --with-modperl --install
>>NOTE: I had desesperatily tried both lines with the same result.
>>make install
>>make initialize-database
>>Everything at this point seems good, the install said that everything 
>>goes fine, and  before of adding the rt3 config file to the apache, it 
>>works fine (apache + modperl) but after adding this file to apache conf.d 
>>directory it is not working:
>><VirtualHost IP ADDRESS>
>>    ServerName xxx.xxxx.es
>>    DocumentRoot /usr/local/rt3/share/html
>>    AddDefaultCharset UTF-8
>>  # these four lines apply to Apache2+mod_perl2 only: {{{     <<< I had 
>> tried commenting this lines too.
>>   PerlSetVar MasonArgsMethod CGI
>>   PerlModule Apache2 Apache::compat
>>   RewriteEngine On
>>    RewriteRule ^(.*)/$ $1/index.html
>>  # }}}
>>    PerlModule Apache::DBI
>>    PerlRequire /usr/local/rt3/bin/webmux.pl
>>    <Location />
>>        SetHandler perl-script
>>        PerlHandler RT::Mason
>>    </Location>
>>The Httpd start resutls:
>>/etc/rc.d/init.d/httpd start
>>Iniciando httpd: [Wed Dec 01 15:10:49 2004] [error] Can't load 
>>for module MIME::Base64: 
>>failed to map segment from shared object: Permission denied at 
>>/usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm line 230.\n at 
>>/usr/lib/perl5/site_perl/5.8.5/MIME/Words.pm line 85\nCompilation failed 
>>in require at /usr/lib/perl5/site_perl/5.8.5/MIME/Words.pm line 
>>85.\nBEGIN failed--compilation aborted at 
>>/usr/lib/perl5/site_perl/5.8.5/MIME/Words.pm line 85.\nCompilation failed 
>>in require at /usr/lib/perl5/site_perl/5.8.5/MIME/Head.pm line 
>>123.\nBEGIN failed--compilation aborted at 
>>/usr/lib/perl5/site_perl/5.8.5/MIME/Head.pm line 123.\nCompilation failed 
>>in require at /usr/lib/perl5/site_perl/5.8.5/MIME/Entity.pm line 
>>235.\nBEGIN failed--compilation aborted at 
>>/usr/lib/perl5/site_perl/5.8.5/MIME/Entity.pm line 235.\nCompilation 
>>failed in require at /usr/local/rt3/lib/RT/I18N.pm line 66.\nBEGIN 
>>failed--compilation aborted at /usr/local/rt3/lib/RT/I18N.pm line 
>>66.\nCompilation failed in require at /usr/local/rt3/lib/RT.pm line 
>>48.\nBEGIN failed--compilation aborted at /usr/local/rt3/lib/RT.pm line 
>>48.\nCompilation failed in require at /usr/local/rt3/bin/webmux.pl line 
>>64.\nBEGIN failed--compilation aborted at /usr/local/rt3/bin/webmux.pl 
>>line 64.\nCompilation failed in require at (eval 4) line 1.\n
>>[Wed Dec 01 15:10:49 2004] [error] Can't load Perl file: 
>>/usr/local/rt3/bin/webmux.pl for server nerea-seis.uned.es:0, exiting...
>>I had checked that there is not dependencies installing all required 
>>modules via CPAN.
>>Sorry for my English but I had read nearly 100 post looking for that 
>>problem, with no success..
>>Thanks in advance.
>>Rt-devel mailing list
>>Rt-devel at lists.bestpractical.com

More information about the Rt-devel mailing list