[rt-devel] Greatly increased query time after update to 4.2.9

sunnavy sunnavy at bestpractical.com
Thu Dec 4 11:27:38 EST 2014

Hi Jeff

I can't reproduce this locally(I doubt it's easy to reproduce too because it depends on quite a few things). I would suggest reproduce it on a test env and then "bisect" on an RT git repo to find the criminal commit.


> On Nov 28, 2014, at 1:57 AM, Jeff Albert <jralbert at uvic.ca> wrote:
> Hi Chris,
> Sadly a restart didn't help; the first query after the restart was even worse as the cache got repopulated, and performance has since returned to where I found it immediately after the upgrade. Thanks for the suggestion, though! Has anybody else seen this with 4.2.9 installs?
> Cheers,
> Jeff
> -----Original Message-----
> From: Christian Loos [mailto:cloos at netcologne.de] 
> Sent: Wednesday, November 26, 2014 10:52 PM
> To: Jeff Albert; rt-devel at lists.bestpractical.com
> Subject: Re: Greatly increased query time after update to 4.2.9
> Hi,
> have you tried a mysql restart?
> This fixed it for me (I didn't dig deeper what exactly was the problem).
> Chris
> Am 27.11.2014 um 02:11 schrieb Jeff Albert:
>> I've just updated the development instance of our RT service, which 
>> had been running at 4.0.8, to the latest 4.2.9 in preparation for a 
>> planned production update to follow. Unfortunately, we've hit a 
>> significant
>> snag: the UI is now hugely slow in some views that were relatively 
>> snappy before the update. The slow query log identifies a likely culprit:

More information about the rt-devel mailing list