[rt-devel] RT 4.4.0rc1 issues

Shawn Moore shawn at bestpractical.com
Fri Nov 6 20:26:39 EST 2015

Hi Andrew,

On 2015年11月5日 at 14:52:23, Barnes, Andrew (barnesaw) (barnesaw at ucmail.uc.edu) wrote:
> To test the 4.4 upgrade, I removed all of my local customizations and tried setting the  
> homepage back to a very basic setup.

Thank you. :-)

> [39520] [Thu Nov 5 19:40:23 2015] [error]: Can't call method "loc" on an undefined value  
> at /usr/local/rt4/sbin/../lib/RT/Ticket.pm line 1374.

This looks like a very clear cut mis-merge. 

sub _DurationAsString {
    my $self = shift;
    my $value = shift;
    return "" unless $value;
    if ($value < 60) {
        return $_[0]->loc("[quant,_1,minute,minutes]", $value);
    } else {
        my $h = sprintf("%.2f", $value / 60 );
        return $_[0]->loc("[quant,_1,hour,hours] ([quant,_2,minute,minutes])", $h, $value);

We’ll get this fixed up for rc2. I’ve made a ticket for tracking it: https://issues.bestpractical.com/Ticket/Display.html?id=31453

In the mean time, if you remove “Time Worked” from “My Tickets” (click the Edit button at the top right, then remove TimeWorked from the Show Columns) it should get you back up to speed.

Thanks for your report!

More information about the rt-devel mailing list