[rt-users] rt2.0.0 web ui paths to images+links wrong

Dikeman, Brett brett.dikeman at proactcorp.com
Wed Jun 27 19:27:21 EDT 2001

Hi all,

I'm moving the RT database to a new box, and then importing that into an rt
install(previous install on the old box was 1.0 something.)

I had things working when I used the URL:

but I want it in /rt/, not the root dir of the server(this is how the
previous rt system was set up.)  I tried a bunch of different things and got
nasty MASON errors no matter what I tried.

So, I instead tried setting up a cname "rt.company.com" and changed the
httpd.conf lines to reflect this(namely, ServerName in the VirtualHost

Now, I can go to rt.company.com, login, but the RT gif is broken along with
all the links, which are things like:
for "Home"
for a ticket in the highest-priority-tickets-i-own listing.

etc, which naturally isn't working so hot.

In config.pm:

$WebPath = "/";
$WebBaseURL = "http://rt.company.com";
$WebURL = $WebBaseURL . $WebPath . "/";

which seems right.  Rt however seems to be completely ignoring WebBaseURL.

Here's the VirtualHost statement:

DocumentRoot /home/rt2/WebRT/html
ServerName rt.company.com
PerlModule Apache::DBI
PerlRequire /home/rt2/bin/webmux.pl
<Location / >
 SetHandler perl-script
 PerlHandler RT::Mason

Can anyone offer any advice?  I'm about to try backing out everything and
removing /home/rt2, re-running make install, and then the import script,
etc...but I'd rather not, I'm in somewhat of a time crunch.



More information about the rt-users mailing list