[rt-users] instalation problem

James Adam Sigler hollow1 at cc.gatech.edu
Mon Nov 5 10:27:14 EST 2001

Whats happening is the mysql script which creates and grants rights to the
"rt-user" needs to give rt-user a password which it probably does. Since,
the output did not ask you for a poassword and the database needs on to
log in the user it seems that either the script has a bug or you did not
give the user a password in your Makefile. Check to make sure 1. Your
rt-user is getting assigned a password in your Makefile 2. That your mysql
knows to ask your user for a password. (THis could be a versioning
issue.) in mysql and 3. That the user is even getting put into the
database. If none of these work try rt-2-0-8_02 (the most current
release) which worked for me with one little bug which was pretty easy to 

			-James Adam Sigler-

James Adam Sigler
Research Scientist
College of Computing
Georgia Tech
Phone: 404-385-0391
Office: CoC 211
Email: hollow1 at cc.gatech.edu

On 5 Nov 2001, Vojtech Moravek wrote:

> Hello guys,
> I have problem with rt 2-0-8. After make instal i will get this error
> message :( This is full output from make install
> If somebody have solved this problem, please help me.
> Best regards
> Vojtech Moravek
> vojtech.moravek at cz.tiscali.com
> make install
> mkdir -p //opt/rt2/bin
> mkdir -p //opt/rt2/WebRT/data
> mkdir -p //opt/rt2/WebRT/sessiondata
> mkdir -p //opt/rt2/etc
> mkdir -p //opt/rt2/lib
> mkdir -p //opt/rt2/WebRT/html
> mkdir -p //opt/rt2/local/WebRT/html
> /usr/bin/perl   tools/initdb 'mysql' '/usr' 'localhost' '' 'root' 'rt2'
> create
> Now creating a database for RT.
> Enter the mysql password for root:
> Creating mysql database rt2.
> cp etc/acl.mysql '//opt/rt2/etc/acl.mysql'
> /usr/bin/perl -p -i -e " s'!!DB_TYPE!!'"mysql"'g;\
>                         s'!!DB_HOST!!'"localhost"'g;\
>                         s'!!DB_RT_PASS!!'"rt_pass"'g;\
>                         s'!!DB_RT_HOST!!'"localhost"'g;\
>                         s'!!DB_RT_USER!!'"rt_user"'g;\
>                         s'!!DB_DATABASE!!'"rt2"'g;"
> //opt/rt2/etc/acl.mysql
> bin/initacls.mysql '/usr' 'localhost' '' 'root' '' 'rt2'
> '//opt/rt2/etc/acl.mysql'
> Enter the mysql administrator's database password to create a new user
> for RT
> Enter password:
> Enter the mysql administrator's database password to nondestructively
> reload the database
> Enter password:
> /usr/bin/perl   tools/initdb 'mysql' '/usr' 'localhost' '' 'rt_user'
> 'rt2' insert
> Now populating database schema.
> Enter the mysql password for rt_user:
> Creating database schema.
> DBI->connect(dbname=rt2;host=localhost) failed: Access denied for user:
> 'rt_user at localhost' (Using password: NO) at tools/initdb line 144
> Access denied for user: 'rt_user at localhost' (Using password: NO) at
> tools/initdb line 144, <STDIN> line 1.
> make: *** [initdb.rtuser] Error 255
> [root at tickets rt-2-0-8_01]#
> _______________________________________________
> rt-users mailing list
> rt-users at lists.fsck.com
> http://lists.fsck.com/mailman/listinfo/rt-users

More information about the rt-users mailing list