[rt-users] Hi all, installation woes

Gary Stainburn gary.stainburn at ringways.co.uk
Wed Feb 20 09:06:22 EST 2002

On Wednesday 20 February 2002 1:24 pm, Darrin Walton wrote:
>   |+ > It should, but only if You restart the httpd server.
>   |+ >
>   |+
>   |+ I have restarted the server and it has not made any difference. Anyone
>   | got + any more ideas?
> Just to clarify.  You did indeed stop the webserver, and then start it
> back up?  Not just issuing either an 'httpsdctl|apachectl restart' or
> kill -HUP <pid>.

Initially I did 'service httpd restart' which calls 'apachectl restart'

The I did 'service httpd stop', waited, and then did 'service httpd start'

I've just tried to start from scratch installing RT2 onto a new box, and I 
was going through the make testdeps and had to install HTML::Mason.

During the install, I saw the following:
Testing whether Apache can be started
Syntax error on line 37 of /root/.cpan/build/HTML-Mason-1.04/t/httpd.conf:
Cannot load /etc/httpd/modules/mod_php.so into server: 
/etc/httpd/modules/mod_php.so: cannot open shared object file: No such file 
or directory
Error loading Apache.  This probably indicates a misconfiguration in the 
/root/.cpan/build/HTML-Mason-1.04/t/httpd.conf file.  We will skip all the 
live Apache tests.skipped test on this platform

Could this have anything to do with the PHP conflict that I appear to be 
having on the first box - asuming that the same error occured there.  Further 
down, Mason is reported to be installed properly by CPAN.
Gary Stainburn
This email does not contain private or confidential material as it
may be snooped on by interested government parties for unknown
and undisclosed purposes - Regulation of Investigatory Powers Act, 2000     

More information about the rt-users mailing list