[rt-users] Re: Scalar::Util

Rainer Duffner rainer at ultra-secure.de
Sun Jul 21 14:11:13 EDT 2002

Blackstone, J. David writes: 

>> -----Original Message-----
>> From: Ayan R. Kayal [mailto:ayan.kayal at yale.edu]
>> Sent: Friday, July 19, 2002 2:11 PM
>> To: rt-users at lists.fsck.com
>> Subject: [rt-users] Scalar::Util 
>> Anyone ever seen this when doing a "make testdeps"? 
>> Scalar::Util not detected - container() method not available 
>> I looked for it on CPAN, but it said that the latest version came with
>> Perl 5.8.0 and would only install if I did a force.
>   I saw it and went ahead and installed Scalar::Util with perl5.6.1 
>   -MCPAN -e 'install Scalar::Util' .  
> Then I ran make testdep again and it had gone  away. 
>   Of course, that was two days ago when I was working with 5.6.1. :)  
>   (Are you on 5.6.1 or 5.8.0?)

I tried that, but when run, it just refuses to install Scalar::Util.
When I try with "force", it wants to go ahead and install PERL 5.8.0 ! 

This is on FreeBSD 4.6, with Perl 5.6.1 in /usr/local/bin/perl
and /usr/bin/perl linked to that temporarily. 

Is Scalar::Util really only part of 5.8 ? 

What else can be done ? 

Rainer Duffner                   Munich
rainer at ultra-secure.de          Germany
http://www.i-duffner.de        Freising
    When shall we three meet again
  In thunder, lightning, or in rain?

More information about the rt-users mailing list