[rt-users] Trying to fix a broken install of RT2.0.13

RT2 Troubles rt2trouble at morben.ca
Fri Jul 26 18:04:49 EDT 2002

I had RT up and running, checking mail, sorting it, assigning tickets, 
auto-responding, and sending mail when I reply to a ticket. 

Then I started adding toys from the contrib section and somewhere along the 
line RT stopped sending mail on reply. It still sends mail as an 
auto-responder, and when I resolve a ticket, but not when I reply to a ticket. 
The other symptom is that the scrips area is messed up and doesn't show any 
of the entries.

I tried the following to fix it:

Backed up config.pm
Unpacked RT2.0.14
Edited the makefile
make testdeps (just for fun - it was fine)
make upgrade

... That just gave me some errors about //etc/config.pm ? 
But I don't have a config.pm in /etc, much less //etc ??

So then I copied the /usr/local/mysql/data/rt2 dir to rt2backup..
Did a mysqladmin drop rt2..
Moved /usr/local/rt2 to rt2backup..
Then I tried make install and the script asked me for a password to create a 
new rt2 DB as "root at localhost" ?! 
If I use "mysqladmin create rt2" .. I don't need a password.

I had to put everything back to stop bouncing my mail and now I'm back to how 
I was, still unable to reply to tickets..

Anyone want to mock my process and perhaps suggest a better method of getting 
RT to resume sending mail when I reply to a message?

Could I just create an rt2 db, comment out the db init portion of the 
makefile, and then swap the new rt2 db for the old one, or would that break 
the db schema? Could I do that if I used the same version of RT that I am 
currently running?


PS: Yeah I forgot my root password for mysql.. ;P

More information about the rt-users mailing list