[rt-users] "Tickets" search function fails -- SOLVED

Scott Courtney scott at 4th.com
Sat Dec 3 14:57:15 EST 2005

On Saturday 19 November 2005 18:30, Scott Courtney wrote:
> To those of you who are Perl geeks, which I am not, this may be a dumb question,
> but I'm trying to figure out why I have the following error in RT 3.4.4:
> error:   Can't locate object method "new" via package
>  "RT::Interface::Web::QueryBuilder::Tree" at 
>  /home/local/rt-3.4.4/share/html/Search/Build.html line 509.

I've solved this problem, thanks in part to a "shotgun" suggestion from Alex
Moura. Alex's suggestion didn't fix the problem, but trying it led me to an
error message that in turn led me to the answer.

I documented the solution, with a couple of reference URLs, on the Wiki
at this page: http://wiki.bestpractical.com/index.cgi?TroubleShooting. If
I did something wrong there, someone in authority please feel free to correct
me on it.

Alex, thanks for the emailed suggestions. You pointed me in the right
direction, even if you didn't directly have the exact solution! :-)


Scott Courtney         | "I don't mind Microsoft making money. I mind them
scott at 4th.com          | having a bad operating system."    -- Linus Torvalds
http://4th.com/        | ("The Rebel Code," NY Times, 21 February 1999)
                       | PGP Public Key at http://4th.com/keys/scott.pubkey

More information about the rt-users mailing list