[rt-users] database initialization error

TeleMole telemole at gmail.com
Wed Dec 7 23:28:12 EST 2005

thanks for the hint - the make test was of course failing completely -
more googling made it clear that I was not finding some libs during
the test.

I tried several methods including placing the
--libs=-L/usr/local/mysql/lib switch on the perl Makefile.PL - but
even this had no effect.

Eventually I foud a reference which is a little cheesy - but did the trick :

Quoted here : "That did it.  Just did "cp /usr/local/mysql/lib/*
/usr/lib/" and it worked
fine after that."

I did the same , then re-ran my make and my make test - and all was
well!  Just got my database initialized!  I hope this helps others
with this problem - though I am certain my mysql installation should
have been otherwise and this is why i ran into trouble in the first

thanks again for putting me on track!


On 12/7/05, Ruslan Zakirov <ruslan.zakirov at gmail.com> wrote:
> Try to reinstall DBD::mysql module and be sure to run test phase of this module.
> On 12/8/05, TeleMole <telemole at gmail.com> wrote:
> > Hey everyone,
> >
> > I have scoured a little for this and found no answers as yet,
> >
> > I am doing an installation of RT and have passed my 'make testdeps'
> > with flying colours, but when I run my 'make initialize-database' I
> > get the following error:
> >
> > /usr/local/bin/perl: relocation error:
> > /usr/local/lib/perl5/site_perl/5.8.7/i686-linux/auto/DBD/mysql/mysql.so:
> > undefined symbol: mysql_init
> > make: *** [initialize-database] Error 127
> >
> > I am using RHEL3 and mysql and as you can see perl 5.8.7
> >
> > can anyone shed some light - I am at an impass until I can solve this one..
> >
> > cheers, and thanks in advance.
> >
> > Sean Daniels
> --
> Best regards, Ruslan.

More information about the rt-users mailing list