[rt-users] Can't build Module::Build (needed by Log::Dispatch) for RT3.4RC1

Lee Roth bwc_lr1 at easy48.com
Wed Jan 12 22:38:59 EST 2005

>Steve Wampler wrote:
> >
> > I'm trying to install RT3.4RC1 on Fedora Core 3 with Perl 3.8.5.
>Sigh.  That's "Perl 5.8.5, of course..."
> > Log::Dispatch won't install because it needs Module::Build, which
> > fails its tests miserably.  The first error is an "Argument list too
> > long" message.
> >
> > I thought I'd tracked the problem down (via archive search) to
> > Test::Harness, which I upgraded to 2.44.  That hasn't helped.
> >
> > Any ideas what's happening?  Fix?
> >
> > Thanks!

I ran into the same problem trying to build modules (via CPAN>)
for RT3.2 - the install of Log::Dispatch wanted to build Module::Build
and that blew up.

I solved this by downloading the kit for Module::Build (from 
http://tinyurl.com/66nfn )
and doing a 'traditional' install/build outside of the CPAN> gizmo (note: 
be sure to
follow the steps in the INSTALL file inside the tarfile). After that, I 
fired up CPAN> again
and it was able to do the 'install Log::Dispatch' just fine.

Lee Roth
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20050112/d78380ff/attachment.htm>

More information about the rt-users mailing list