[rt-users] RTx::Shredder question

Andy Moran andy at wildbrain.com
Tue Oct 4 12:19:02 EDT 2005

This question is probably more for Ruslan, but I thought I'd email the
list in case it's something obvious.

On a test system, we shredded about 25000 tickets in our Spam queue and
that all went well.. took about 4 days.  (I had to hack the rtx-shredder
script so it wouldn't write the sqldump restore files to save on disk

Then I disabled all 22000 spammer user accounts (we only have about 100
real accounts), and tried shredding all 22000 disabled accounts.  It ran
for an hour and then died with this error:

[Mon Oct  3 17:34:18 2005] [crit]: couldn't find resolver for dependency
'RT::User-37898 (depends on,resolvable dependency) RT::Ticket-3612' at
/usr/local/rt3/lib/RTx/Shredder/Dependency.pm line 87, <STDIN> line 1.

I tried running the script again and this time i got a slightly
different but similar error:

[Mon Oct  3 17:43:22 2005] [crit]: couldn't find resolver for dependency
'RT::User-66 (depends on,resolvable dependency) RT::Attachment-1865' at
/usr/local/rt3/lib/RTx/Shredder/Dependency.pm line 87, <STDIN> line 1.

Every time after that I tried to run it, it would immediately die with
the same error.

So my question:   Is this because the some disabled users might still
own tickets?   Or could it be that in shredding my spam tickets, i
messed up my database somehow and now can't shred my disabled users?

I'm using the CLI of version 0.02_02.



More information about the rt-users mailing list