[rt-users] Problems installing 3.4.4 with Postgres on FC3

Phil Smith III lists at akphs.com
Sun Oct 9 16:53:18 EDT 2005

I ran the install and, after some struggles, got all the dependencies to be happy.

But when I did "httpd start", it complained that Apache2.pm wasn't found.  @INC is close -- it includes:
But Apache2.pm was in 
along with  ApacheTest.pm  and  DBI.pm.

I copied Apache2.pm to 
and then it complained that Apache/compat.pm wasn't found.  So I copied that to
and then it complained that DBI.pm wasn't found.

That one was in the installation info, so I did the
	perl -MCPAN -e 'install Apache::DBI'
(which presumably (?) would have solved the other 2 problems -- but why didn't the installation get this one right?) and then httpd started, but complained:
	 No root path(s) specified at /opt/rt3/bin/webmux.pl line 99
and visiting the root URL got a 404:
	The requested URL /index.html was not found on this server.
which at least seems consistent with it being confused about the root path.  

Googling and searching the archives suggests that there's a bug that causes something (webmux.pl?) to be run twice, and that adding:
	system("touch $RT::MasonDataDir/obj/fake_file");
to webmux.pl (presumably just before the failure) is the fix.

So I did that, and now httpd starts cleanly, but still 404s.  The DocumentRoot statement reads:
   DocumentRoot /opt/rt3/share/html
and there is an index.html in that directory.  Googling for this one didn't seem to shed any light.

I feel like I've made progress, but I'm not there yet, and can't really even tell if I'm moving in the right direction.  Any and all suggestions are appreciated.

Least hypothesis is that I don't understand the section about configuring httpd.conf.

RT is the only web service on that machine.

The section I added to httpd.conf is (IP/hostname changed):

   ServerName my.servername.com
   DocumentRoot /opt/rt3/share/html
   AddDefaultCharset UTP-8

   # this line applies to Apache2+mod_perl2 only
   PerlModule Apache2 Apache::compat

   PerlModule Apache::DBI
   PerlRequire /opt/rt3/bin/webmux.pl

   <Location />
       RedirectMatch permanent (.*)/$ http://levanta.com$1/index.html
       SetHandler perl-script
       PerlHandler RT::Mason

Disclaimer: I'm far from a Linux expert.  So if I've done something wildly stupid (likely!), be gentle ;-)


More information about the rt-users mailing list