[rt-users] rt344 on solaris 9, syslog error

Luke Vanderfluit lvanderf at internode.com.au
Tue Oct 11 03:20:50 EDT 2005


Ruslan Zakirov wrote:

>On 10/11/05, Luke Vanderfluit <lvanderf at internode.com.au> wrote:
>>I'm installing rt3.4.4 on solaris 9.
>>I've come across the syslog bug.
>>The one that gives you this output when you try to log in:
>>*error:*  no connection to syslog available at
>>line 77
>>I've tried the fix that mentions putting:
>>@LogToSyslogConf = ( ) unless (@LogToSyslogConf);
>>@LogToSyslogConf = ( socket => 'inet' ) unless (@LogToSyslogConf);
>>However, this fix doesn't work for me.
>>I think I might have to edit RT.pm.
>>Any suggestions?
>You need to put: "@LogToSyslogConf = ( socket => 'inet' );" without
>unless and restart RT server. *Stop and start*
I've done the following from the source tree.
./configure --with-db-rt-pass='somepass' --prefix=/usr/local/rt3

perl sbin/rt-test-dependencies --with-mysql --with-modperl1
shows up with everything found.

make install went fine.

Then I have the following section in my RT_SiteConfig.pm:

Set($LogToSyslog    , '');
Set($LogToScreen    , 'debug');
Set($LogToFile      , 'debug');
Set($LogDir, '/usr/local/rt3/var/log');
Set($LogToFileNamed , "rt.log");    #log to rt.log

# On Solaris or UnixWare, set to ( socket => 'inet' ).  Options here
# override any other options RT passes to Log::Dispatch::Syslog.
# Other interesting flags include facility and logopt.  (See the
# Log::Dispatch::Syslog documentation for more information.)  (Maybe
# ident too, if you have multiple RT installations.)

#@LogToSyslogConf = () unless (@LogToSyslogConf);
@LogToSyslogConf = ( socket => 'inet' ); #unless (@LogToSyslogConf);
I restarted the webserver and still got the same error.
Then I stop httpd and made sure no httpd was running.
Then started the server and it worked.

However now I can't log in.
I've tried "root":"somepass"
somepass is the same password as I used with ./configure 

But I couldn't get it.
Then I tried "rtuser":"somepass" as they are set the RT_SiteConfig.pm file.
That didn't work either.

Which username and password combination is the one to use for an initial 



More information about the rt-users mailing list