[rt-users] Still having trouble getting RT started for the first time

Phil Smith III lists at akphs.com
Wed Oct 19 15:38:18 EDT 2005

I'm getting closer, but still having trouble getting RT started.  It's a fresh intall on FC3 using mod_perl-2.0.1-1.fc4 and associated bits.

The machine it's running on is our ftp host, but has no other web services running on it at the moment.  However, there is an index.html in /var/www/html.  And as I tinker with httpd.conf, I'm getting one of three symptoms, depending on how I tinker:

1) The index.html in /var/www/html
2) A download that Firefox claims is a unix directory, but which downloads to a zero-length file
3) The "You're almost there!" page.

Now, all this suggests to me that (3) is the "best" configuration, though obviously still not right: it's clearly paying attention to the VirtualHost section I added, since if I tinker with that, the behavior changes.  It seems to me that (as the "You're almost there!" page suggests) the problem is that Apache isn't running the Perl "stuff" when the URL is visited.  But I can spell "Apache" and that's about it.  I've done lots of Googling for various Apache documents, and don't seem to be getting any closer.  (A colleague who has worked with Apache has tinkered as well, and he's stumped too.)

Here's what I have now (hostname and IPs changed to protect the guilty, of course):

<VirtualHost rt.example.com>
   DocumentRoot /opt/rt3/share/html
   ServerName rt.example.com

   # this line applies to Apache2+mod_perl2 only
   PerlModule Apache2 Apache::compat

   PerlModule Apache::DBI
   PerlRequire /opt/rt3/bin/webmux.pl

   <Location /rt>
       AddDefaultCharset UTF-8
       SetHandler perl-script
       PerlHandler RT::Mason

Is there anything obviously wrong?  (Besides that fact that it's not working!)


More information about the rt-users mailing list