[rt-users] Trouble with initializing database

Russ rt at notreally.mine.nu
Wed Feb 1 05:47:49 EST 2006


I am attempting a new installation of Request Tracker on Gentoo.  I have 
emerge'd rt using the provided ebuild and all required dependencies. I 
am at the stage where I am initializing the database for the first time, 
and this is where I am encountering some problems.

Running the command
/var/www/rt/rt-3.4.5/sbin/rt-setup-database --action init --dba root 
results in:

Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
Done setting up database schema.
Now inserting database ACLs
DBD::mysql::db prepare warning:  at ./rt-setup-database line 347.
Died at ./rt-setup-database line 347.

The database and many tables have been created, but no data in any off 
them.  I have modified the rt-setup-database command switches to use the 
user account specified in the RT_Config.pm file after granting that 
account all the required privileges needed, same result. 

In case it was a faulty ebuild I grabbed the latest source and compiled 
it manually with the same result with 'make initialize-database'.

Version numbers:
Apache:  2.0.55-r1
mod_perl: 2.0.1-r2
MySQL: 5.0.18-r30

Let me know if I need to provide anymore information.



More information about the rt-users mailing list