[rt-users] Scalar::Util::Weak Problem (Fixed!)

jkaufman at footlocker.com jkaufman at footlocker.com
Wed Feb 8 12:46:36 EST 2006

It would seem the end fix would be to upgrade to perl 5.8.8 :)

Along the way I also upgraded

Aix v5.3 ML03+
GCC v4.0.2
Automake v1.9.6
Bison 2.0
Libtool 1.5.22
m4 1.4.3
pkgconfig 0.19

But nothing was working until I noticed 5.8.8 on the perl website and then 
like magic...it works now :)

Jonathan Kaufman

Foot Locker Corporate Services, Inc.
E-Mail: jkaufman at footlocker.com
Tie Line:89-221-4062

Sent by: rt-users-bounces at lists.bestpractical.com
02/06/2006 07:08 AM

rt-users at lists.bestpractical.com

Re: [rt-users] Scalar::Util::Weak Problem (Still Broken)

I suppose I should have mentioned that. The 'make' that ships with AIX 
seems to be bad when it comes to compiling OSS type stuff. So I've 
replaced it with GNU Make v3.8, along with gettext v0.10.40, flex v2.5.4a, 
libtool v1.5.8, readline v4.3, bison v1.875, autoconf v2.59, automake 
v1.8.5, expat v1.95.2, m4 v1.4.1 

They are all official IBM rpms from the Linux Toolbox for AIX. 

I don't suppose anyone notices a version conflict in what I've just 

I've already changed the LIBPATH to /opt/freeware/lib:/lib:/usr/lib (and 
kept it unset) to no avail. I've tried using GCC v3.3.2, and VAC v5.0, 7.0 
and 8.0. 

Nothing seems to be working. I've tried starting from source using all the 
aformentioned C compilers....Nada.. 

I expect there is an incompatibility *somewhere*....But where that is...I 
have no idea.   

Jonathan Kaufman

Foot Locker Corporate Services, Inc.
E-Mail: jkaufman at footlocker.com
Tie Line:89-221-4062 

02/03/2006 02:19 PM

jkaufman at footlocker.com 
rt-users at lists.bestpractical.com 
Re: [rt-users] Scalar::Util::Weak Problem (Still Broken)

jkaufman at footlocker.com wrote:

> Once again denied...ugh..   ... [snipped] ...
> make: *** [subdirs] Error 2
>   /opt/freeware/bin/make  -- NOT OK
> Running make test
>   Can't test without successful make
> Running make install
>   make had returned bad status, install seems impossible
> I even went through the trouble of blowing away my perl install, and 
> compiling without threads to see if it's a threading issue (same 
> error)...Sigh... Anyone?

I am wondering if there are incompatible instructions in your Makefile.

Incompatible with your version of 'make', that is. If the Makefile.PL
does not like the AIX /opt/freeware/bin/make, can you provide another one?

If your "freeware" make is GNU make, is it a modern version?

I have rarely gone wrong by forcing other members of the team to 
on GNU make. Well, technically wrong, at least. :)

If your system continues finding an incorrect version of a program or 
library, you
can create a UID zero user who is not root for the duration of the 
install. Then
you can hack the living ... umm, you can really make some profound 
changes to
that new user's environment, including adding or subtracting huge 
sections of
PATH to force certain code to be used in lieu of the system default.

After the install is in production, back up the environment of the 
superuser, and then delete that user.

Please let us know what you tried, and if it works.

Take care,



Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Download a free sample chapter of RT Essentials from O'Reilly Media at 

WE'RE COMING TO YOUR TOWN SOON - RT Training in Amsterdam, Boston and
San Francisco - Find out more at 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20060208/10a5b402/attachment.htm>

More information about the rt-users mailing list