[rt-users] Problem Starting Web Interface

Mon Feb 27 14:45:22 EST 2006

Hi there --

I tried recompiling mod_perl and it appeared to compile with perl 5.8.8.
However, when I tried starting apache with the appropriate modifications, I got
the same error message. 

I checked the /usr/local/lib/perl5 directory, and there are two subdirectories
which read 5.8.8 and site_perl. The original perl directory is located at
/usr/lib/perl5 and has the following subdirectories: 5.8.0, site_perl, and

One idea I had was to rename the /usr/lib/perl5 directory and create a symbolic
link to /usr/local/lib/perl5. Once that is done, I will try to recompile
mod_perl. What are your thoughts?

-----Original Message-----
From: Jesse Vincent [mailto:jesse at bestpractical.com] 
Sent: Friday, February 24, 2006 3:18 PM
To: Kaplan, Andrew H.
Cc: rt-users at lists.bestpractical.com
Subject: Re: [rt-users] Problem Starting Web Interface

> Can't locate Apache/DBI.pm in @INC (@INC contains:
> /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
> /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
> /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
> /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
> /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl
> /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 .
> /usr/local/apache/ /usr/local/apache/lib/perl) at (eval 5) line 3.

Looks like your mod_perl is built against perl 5.8.0.

More information about the rt-users mailing list