[rt-users] rt command line features broken?

David Smithson dsmithson at activsupport.com
Tue Jul 11 01:25:41 EDT 2006

Hi all.  The rt command line tool doesn't seem to have the feature that
it says it has.  Anyone else run into this?  See below:

[root at rt ~]# rt help group

Users and groups are identified by name or numeric ID.

The following generic operations may be performed upon them:

    - list
    - show
    - edit
    - create

In addition, the following type-specific actions exist:

    - grant
    - revoke


    The following attributes can be used with "rt show" or "rt edit"
    to retrieve or edit other information associated with users and

    rights                  Global rights granted to this user.
    rights/<queue>          Queue rights for this user.

So, according to this, I should be able to run a command like `rt show
group/<mygroup>/rights`.  However, when I run that, I get:

[root at rt ~]# rt show group/<mygroup>/rights
# Unknown object type: group

id: group/<mygroup>/rights

I get the same error when I run `rt show group/<mygroup>`

Is it possible that the documentation came before the implementation?

David Smithson

More information about the rt-users mailing list