[rt-users] rt-mailgate config problems while on virtual dedicated server

Phil Lawrence phil at five-lawrences.com
Sun Aug 26 14:19:14 EDT 2007

I'm having problems properly configuring rt-mailgate. I have a recipe
I made a few years ago for RHEL 4, but I had a real dedicated box that
time.  This time I have a dedicated virtual server hosted by godaddy.

I started with the fancy method described at
http://www.geert.triple-it.nl/node/rt_procmail.html, but soon realized
my root problem with that method was that I didn't know how to deliver
mail to an actual account on the box from postfix, which is using
virtual_alias to handle mail for my virtual domain.

So I went back to the basic way descried in manual_installation, where
you set up an alias for each queue.

postfix wouldn't let me put this in /etc/postfix/turbopanel/virtual_alias:
test at virtualdomain.com "|/opt/rt3/bin/rt-mailgate --queue test
--action correspond --url https://virtualdomain.com"

It complained because it wasn't a valid hash format.

So I tried appending to /etc/aliases:
test: "|/opt/rt3/bin/rt-mailgate --queue 'test' --action correspond
--url https://virtualdomain.com"

and setting /etc/postfix/turbopanel/virtual_alias:
test at virtualdomain.com test at ip-999-999-999-999.ip.secureserver.net

that failed (relay error, I suppose another machine is actually
handling ip-999-999-999-999.ip.secureserver.net)

So I tried /etc/postfix/turbopanel/virtual_alias:
test at virtualdomain.com test at localhost

which resolved to test at locahost.virtualdomain.com, and so failed:
Aug 25 12:37:41 ip-999-999-999-999 postfix/lmtp[27984]: 3F34315E35F6:
to=<test at localhost.virtualdomain.com>,
relay=/var/lib/imap/socket/lmtp[/var/lib/imap/socket/lmtp], delay=0,
status=bounced (host
/var/lib/imap/socket/lmtp[/var/lib/imap/socket/lmtp] said: 550-Mailbox
unknown.  Either there is no mailbox associated with this 550-name or
you do not have authorization to see it. 550 5.1.1 User unknown (in
reply to RCPT TO command))

I also tried /etc/postfix/turbopanel/virtual_alias:
test at virtualdomain.com test at

and that failed:
Aug 25 12:40:36 ip-999-999-999-999 postfix/qmgr[28422]: 9AEA715E35F6:
to=<test at>, relay=none, delay=0, status=bounced (bad address
syntax: "test at")

I'm using RT 3.6.4 on CentOS 4.5 with postfix and cyrus.

Can anyone point me in the right direction?

Phil Lawrence

More information about the rt-users mailing list