[rt-users] Clicking a link brings me back to login page

oakcluster oakcluster at comcast.net
Thu Apr 24 23:09:53 EDT 2008

Juan Mas wrote:
> Hi All,
> I just got RT 3.6.6 installed on gentoo and followed the installation
> instructions step by step.  I am able to get to the login page and
> login using root, but when I click on any link it brings me back to
> the login screen.  I can then log in and it will take me to where I
> need to go but I have to do this after every link I click.  I tried
> searching the archives but didn't find any answers.  Does anyone know
> a solution to this?

Make sure the following are set correctly in your RT_SiteConfig.pm file:

Set( $WebBaseURL , "http://rt.path.domain.com");
Set( $WebPath , "/");

My WebPath was set wrong. It was based on an older configuration where
it was set to /rt3.
When it was set to the older config I would always go back to the login
page. when I clicked on a link.

After I changed it it worked fine.

More information about the rt-users mailing list