[rt-users] No recipients found. Not sending. SendEmail.pm:250

Charnjit Sidhu c.sidhu at bham.ac.uk
Tue Apr 29 12:02:38 EDT 2008



I know this has been posted before on the mailing lists but the issue I have is not consistant.

When updating and resolving a ticket from the system, Reply to requester and cc from a ticket works when sending an email out form the RT system if sent by user Root, however when I try to do the same as a normal user it does not work, and the only message I receive in /var/log/messages is:

No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:250)

The odd thing is I can send emails out from a normal user to external email addresses, the only difference I can see in the name is a dot ie:

j.smith at domain.com  will not work

but if I send an email to j1234 at domain.com it works.

if the dot in the local part of the email address is the issue then should the issue also occure when sending to the same address from root? 

Also When the ticket is created through an email the autoreply works and sends out a message without any problems.

It may have something to do with file permissions, but I have given superuser functionality to all users in RT, but the problem still persists.

Have been looking at this issue for over a week and am stuck, as it is not consistent. After reading the posts I have tried making the changes suggested like adding watchers and checking file permissions but none have worked.


More information about the rt-users mailing list