[rt-users] RT permission question

Kenneth Crocker KFCrocker at lbl.gov
Wed Dec 17 18:12:15 EST 2008


	Here's another interesting test result; I had this same user create a 
ticket in MY queue, which allows any privileged user the "SeeQueue" and 
"CreateTicket" rights. Then I had this person create a ticket in his own 
queue, make himself owner and then try to move it to my queue, No joy.?????


On 12/17/2008 12:27 PM, Stephen Turner wrote:
> On Wed, 17 Dec 2008 15:22:24 -0500, Kenneth Crocker <KFCrocker at lbl.gov> 
> wrote:
>> Stephen,
>>     I tried the following tests:
>>     1) added rights to the first group for target queue. No Joy.
>>     2) tried to have owner move ticket to a queue that allowed any
>> privileged user to "CreateTicket". Also no joy.
>>     I'm dumbfounded. He IS a privileged user or I wouldn't be able to 
>> have
>> him in a group. Of course, I checked anyway.
>> Kenn
> Kenn,
> Does your user have ModifyTicket on the "from" queue?
> One way to really get to the bottom of this is a Perl script that 
> (logged on as your user) uses the API to read the ticket and attempts to 
> change the queue. Stepping through the code using the debugger should 
> show you exactly where the "permission denied" is happening and should 
> help you figure out why.
> Steve

More information about the rt-users mailing list