[rt-users] fastcgi setup (debian, rt3.6, apache2

Tom Vier tom at triadsys.com
Mon Jan 7 13:49:34 EST 2008

Now i'm stumped. I have both apache2 and mysql running on this machine.
RT works if i access using or it's lan address. However, if i
try the lan address from another machine on the lan, only the login
screen works. After you click login, the browser goes to /index.html
(empty file in /var/www/) instead of /rt/index.html. The html source
shows the post action as "index.html" from a local browser and from
another machine (using both firefox and ie).



Include /etc/request-tracker3.6/apache2-fastcgi.conf

NameVirtualHost *
<VirtualHost *>
         ServerAdmin webmaster at localhost

         DocumentRoot /var/www/
         <Directory />
                 Options FollowSymLinks
                 AllowOverride None
#               tried these two lines, no help:
#               Order allow,deny
#               Allow from all

         <Directory /var/www/>
                 Options Indexes FollowSymLinks MultiViews
                 AllowOverride None
                 Order allow,deny
                 allow from all
                 # This directive allows us to have apache2's default 
start page
                 # in /apache2-default/, but still have / go to the 
right place
#               disabling this makes no diff:
#                RedirectMatch ^/$ /apache2-default/

         ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
         <Directory "/usr/lib/cgi-bin">
                 AllowOverride None
                 Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                 Order allow,deny
                 Allow from all

         ErrorLog /var/log/apache2/error.log

         # Possible values include: debug, info, notice, warn, error, crit,
         # alert, emerg.
         LogLevel debug

         CustomLog /var/log/apache2/access.log combined
         ServerSignature On

     Alias /doc/ "/usr/share/doc/"
     <Directory "/usr/share/doc/">
         Options Indexes MultiViews FollowSymLinks
         AllowOverride None
#        Order deny,allow
#        Deny from all
#        Allow from ::1/128




# You might want to enable this line
# AddDefaultCharset UTF-8

# These are set properly by the libapache2-mod-fastcgi package
AddHandler fastcgi-script fcgi
#FastCgiIpcDir /var/run/fastcgi

# Tell FastCGI to trigger on the handler
FastCgiServer /usr/share/request-tracker3.6/libexec/mason_handler.fcgi

# Bypass FastCGI for images
Alias /rt/NoAuth/images /usr/share/request-tracker3.6/html/NoAuth/images

# Use the handler for everything else
ScriptAlias /rt /usr/share/request-tracker3.6/libexec/mason_handler.fcgi

<Location /var/www/rt/>
  DirectoryIndex /rt/html/index.html
# these made no diff:
# Order deny,allow
# Allow from all

Tom Vier <tom at triadsys.com>
Sysadmin - Support Technician
Triad Systems Engineering, Inc.

Tom Vier wrote:
> I got it working. The suexec module wasn't enabled and i was including 
> the rt config inside a virtual host (i just moved it up a level to the 
> first line of site-enabled/rt).
> -- 
> Tom Vier <tom at triadsys.com>
> Sysadmin - Support Technician
> Triad Systems Engineering, Inc.
> Tom Vier wrote:
>> Same problem, unfortunately. I have both installed. Apache complains 
>> that FastCgiIpcDir and FastCgiServer are invalid commands, when i 
>> include rt's apache2 conf file in sites-enabled/rt.
>> I have these files, so i looks to me like it should be loading those 
>> modules.
>> tom:/etc/apache2# cat mods-available/fastcgi.conf
>> <IfModule mod_fastcgi.c>
>>   AddHandler fastcgi-script .fcgi
>>   #FastCgiWrapper /usr/lib/apache2/suexec2
>>   FastCgiIpcDir /var/lib/apache2/fastcgi
>> </IfModule>
>> tom:/etc/apache2# cat mods-available/fcgid.conf
>> <IfModule mod_fcgid.c>
>>   AddHandler fcgid-script .fcgi
>>   SocketPath /var/lib/apache2/fcgid/sock
>>   IPCConnectTimeout 20
>> </IfModule>
>> and i've tried with both fastcgi:
>> lrwxrwxrwx 1 root root 30 2007-12-26 11:29 fastcgi.conf -> 
>> ../mods-available/fastcgi.conf
>> lrwxrwxrwx 1 root root 30 2007-12-26 11:29 fastcgi.load -> 
>> ../mods-available/fastcgi.load
>> and fcgid modules enabled (never both, in case they conflict).
>> -- 
>> Tom Vier <tom at triadsys.com>
>> Sysadmin - Support Technician
>> Triad Systems Engineering, Inc.
>> Emmanuel Lacour wrote:
>>> On Fri, Dec 21, 2007 at 04:49:04PM -0500, Tom Vier wrote:
>>>> I'm trying to use libapache2-mod-fcgid (debian apparently has a problem 
>>> libapache2-mod-fastcgi != libapache2-mod-fcgid
>>> install libapache2-mod-fastcgi, and it should works ;)
> _______________________________________________
> http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users
> If you sign up for a new RT support contract before December 31, we'll take
> up to 20 percent off the price. This sale won't last long, so get in 
> touch today.    Email us at sales at bestpractical.com or call us at +1 617 
> 812 0745.
> Community help: http://wiki.bestpractical.com
> Commercial support: sales at bestpractical.com
> Discover RT's hidden secrets with RT Essentials from O'Reilly Media. Buy 
> a copy at http://rtbook.bestpractical.com

More information about the rt-users mailing list