[rt-users] Mysqldump 3.6.3 -> 3.6.5 ( attachments )

James Moseley jmoseley at corp.xanadoo.com
Tue Jan 15 14:23:29 EST 2008

Your mysqldump syntax looks fine, although depending on the version you are
running, the 'add-drop-table' argument is redundant since you are using

To rule out a DB problem, have you tried using your 3.6.5 SUSE instance of
RT with the DB sitting on the RedHat box?  If you get the same behavior,
then I think it's safe to say you probably don't have a DB problem but
something else wrong - missing perl module, apache fastcgi/mod_perl issue,
database/RT permissions, etc.

Have you looked at the RT or Apache logs yet?

James Moseley

             "Roy Sowa"                                                    
             <Roy.Sowa at rcmp-gr                                             
             c.gc.ca>                                                   To 
             Sent by:                  <rt-users at lists.bestpractical.com>  
             rt-users-bounces@                                          cc 
             al.com                                                Subject 
                                       [rt-users] Mysqldump 3.6.3 -> 3.6.5 
                                       ( attachments )                     
             01/15/2008 12:36                                              

I am in the process of moving my existing RedHat 3.6.3 install to a SUSE 10
3.6.5 box ...
I thought all was going well, but I just stumbled into a problem...

I had been using  the following mysqldump ;
mysqldump --opt --add-drop-table --single-transaction ........ rt3 >

and this restores nicely.. ( I thought I was good to go ).
the records look correct and I see the attachment links in the tickets that
have them, But
now when I try and view an attachment  by clicking on the link  it says
"page not found"....
the url link matches the search format of that of the original working
server ...

what I have tried so far...

A few searches surfaced that I might try adding this to my dump statement

but this did not change things...

Trying to create a new ticket with a simple attachment also does not
Funny enough If I attach a simple gif, I see the gif in the newly created
ticket, however I just cannot click on the download link in the transaction
or the link in the attachment area... ( page not found...)

So then I found this snippet  RE: binary attachment corruption;

Hello, Chris.
Could you backup your DB, and run next to SQL queries?
Then check if you could binary attachments without problems and report
This query is safe but anyway I would suggest you to backup data. .....

This did not change results either...

I really would like to convert  to the newer server/hardware....

any suggestions as to where I went wrong or how to move this forward ???


Community help: http://wiki.bestpractical.com
Commercial support: sales at bestpractical.com

Discover RT's hidden secrets with RT Essentials from O'Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

More information about the rt-users mailing list