[rt-users] Error on including RTFM Article in Answer to Ticket

Kevin Falcone falcone at bestpractical.com
Thu Apr 23 13:01:36 EDT 2009

On Apr 23, 2009, at 12:21 PM, who else wrote:

> I'd like to bring up this apparently old one, because someone got me  
> on the
> right track, although he isn't on this list. So i'll share, what he  
> said,
> and finally got me out of this mess:
>> Wanted to let you know I found what your problem is in your RTFM
>> article attachment. I was having the same issue and finally saw our
>> problem based on yours. The issue is something to do with the way it
>> parses the organization name in your RT_SiteConfig.pm if there is a
>> space in that name RTFM doesn't know how to handle it. Yours  
>> apparently
>> ends in IT, mine ended in Inc. I just changed my organization name to
>> not have spaces and it worked like a charm.
>> It would be good if you go ahead and respond to your initial rt-users
>> post with the solution so anyone else who experiences the problem can
>> find the solution. I would but I've never joined the list. Hope this
>> helps you as it did me.

I will note that the docs for Organization say:
"You should set this to your organization's DNS domain"
Which presumably doesn't have a space in it.

I've bounced your email into the bugtracker because we may want
to either handle this case or warn in the logs if Organization looks


> In fact, this was indeed the problem, so now it works and perhaps  
> you'll
> find this, if you run in this problem.
> Best
> w_e
> who else wrote:
>> Hi there,
>> after reading the chapter about custom fields in "RT Essentials" i
>> thought, setting rights on the custom field, like this:
>> everybody "show custom field"
>> privileged "show custom field"
>> privileged "edit custom field"
>> could do the trick, but no way, the error won't go away.:-(
>> Best
>> w_e
>> who else wrote:
>>> Hi all,
>>> am a newbie with RT and RTFM, but got it up and running for two  
>>> days now.
>>> I figured out a lot of things myself, and besides buying RT  
>>> Essentials,
>>> which will amazon will ship today, and checking out various  
>>> options in
>>> RT, i got a weird Errormessage, where neither Uncle Google finds  
>>> anything
>>> nor Auntie Searchbutton here in the list archives.
>>> So, the error message is:
>>> Can't call method "Id" on an undefined value at
>>> /opt/rt3/local/plugins/RT-FM/lib/RT/URI/fsck_com_rtfm.pm line 133.
>>> What happened before:
>>> I configured RTFM, created two classes and a bunch of topics, as  
>>> well as
>>> a wikitext entry user defined field, to be able to enter the long  
>>> version
>>> of the summary. Then i entered some articles to check out the  
>>> article
>>> integration in RT
>>> I opened a new ticket and clicked on answer. Then i selected an  
>>> Entry of
>>> RTFM to be included in the answer. Which was shown in the text  
>>> editor
>>> after i made changes to another field and hit the Enterkey. I  
>>> selected
>>> the entry by popuplist, by entering the article number i got the  
>>> same
>>> errormessage
>>> Then i clicked on the "Update" Button and was presented with the  
>>> error
>>> message above.
>>> I don't claim that my workflow is correct :-), but i was wondering  
>>> about
>>> this error message. Since no search yielded in any information i  
>>> hope
>>> someone here has an idea about this.
>>> RT 3.8.2 (and RTFM 2.4.2 i think it is, latest version) is running  
>>> on
>>> Apache/2.2.3 (Debian) PHP/5.2.0-8+etch13 mod_ssl/2.2.3 OpenSSL/ 
>>> 0.9.8c
>>> mod_perl/2.0.2 Perl/v5.8.8
>>> My apache error.log says something like this:
>>> [warning]: Could not determine a URI scheme for IT/article/3
>>> (/opt/rt3/bin/../lib/RT/URI.pm:139)
>>> (in fact i wanted to include article #3 in the email)
>>> Everything else is seems to run smooth enough, no hiccups  
>>> whatsoever,
>>> currently :-)
>>> It might be a configuration issue, but i haven't any clue, where  
>>> to check
>>> this out.
>>> So, if you got a chance to let me know, where i will have to dig  
>>> deeper
>>> into, i'd be glad. I wouldn't mind a pointer how to fix this either.
>>> Thank you for your time.
>>> Best
>>> w_e
> -- 
> View this message in context: http://www.nabble.com/Error-on-including-RTFM-Article-in-Answer-to-Ticket-tp22247095p23197445.html
> Sent from the Request Tracker - User mailing list archive at  
> Nabble.com.
> _______________________________________________
> http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users
> Community help: http://wiki.bestpractical.com
> Commercial support: sales at bestpractical.com
> Discover RT's hidden secrets with RT Essentials from O'Reilly Media.
> Buy a copy at http://rtbook.bestpractical.com

More information about the rt-users mailing list