[rt-users] ExternalAuth/LDAP.pm line 304, line 273

testwreq wreq testwreq at gmail.com
Tue Aug 10 23:34:21 EDT 2010

We have RT 3.8.2. we have successfully installed the ExternalAuth plugin and
have configured
file, which is called by /rthome/etc/RT_SiteConfig.pm

On the RT User Interface, I get RT Login window, where I am entering my AD
user account and password. It fails  with the following error:
(Can't call method "as_string" on an undefined value at
line 304, line 273.)

My RT_SiteConfig.pm file  looks like this:

I also tried defining group as follows, but same error:

'group'        =>  'CN=Domain Users,CN=Users,DC=cs,DC=sb,DC=edu',

'group_attr'   =>  'member',

I have tried changing the filter to '(&(objectCategory=User)
(ObjectClass=Person))' as well.

#Begin /data/rt3/local/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.pm
in its entirety.

# Tell RT to read the plugin for External Authentication.


Set($ExternalAuthPriority,  ['My_LDAP']);

Set($ExternalInfoPriority,  ['My_LDAP']);

# Tell RT to trust the webserver to handle authentication.

# Set($WebExternalAuth, 3);

# If this is set to true, then the relevant packages will be loaded to use
SSL/TLS connections. At the moment this just means "use Net::SSLeay;"

Set($ExternalServiceUsesSSLorTLS,    1);

# If the webserver hands RT a user RT is not familiar with, RT should just
go ahead and create an account

Set($AutoCreateNonExternalUsers,    1);

Set($ExternalSettings, {

                         'My_LDAP'       =>  {   ## GENERIC SECTION

                                                  'type'    =>  'ldap',

                                                  'server'  => ‘ hostname',

                                                  # 'user'   =>  'recldap',

                                                   'user'  =>  'CN=LDAP
user,OU=Service Accounts,OU=SBC,DC=cs,DC=sb,DC=edu',

                                                   'pass'   =>  'xxx',

                                                   'base'   =>

                                                   'filter'   =>

                                                   'd_filter'  =>

                                                   'tls'      =>  1,

                                                   'ssl_version' =>  3,

                                                   'net_ldap_args' =>
[    version
=>  3   ],

                                                   'group'        =>

                                                   'group_attr'   =>

                                                   'attr_match_list'  => [



                                                   'attr_map'         =>  {
'Name' => 'sAMAccountName',

'EmailAddress' => 'mail'





thank you... vm
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20100810/b0e30a48/attachment.htm>

More information about the rt-users mailing list