[rt-users] Where is my error?

Rezty Felty rfelty2 at hallmark.com
Wed Aug 17 14:24:09 EDT 2011

I have a production RT 3.8.0 instance running on a local Solaris server. I 
have been tasked with migrating it to a remote vmware RHEL Linux instance 
and upgrading to RT 3.8.8 at the same time.  So I installed RT3.8.8 on the 
new server, and then did a MySQL dump of the db from the existing server, 
and moved it over and imported it to the new server, for my test instance 
for the migration.  At first, RTFM did not work, (it would show RTFM, and 
article titles, but if you clicked on one, no article body), there were 
permission errors, I had a few problems.  I engaged RT support for 4 hours 
of paid support, and we worked through all of those issues, and i 
documented all the steps we took.  Then RT on the new server was working 
right and we scheduled a Saturday midnight cutover , the plan was to take 
another dump after shutting down the existing prod RT instance, copy it 
over, do the DB transforms for the upgrade, and all should be well.  I did 
that, and RTFM would not show article bodies again, screens timed out 
opening new tickets, the server could not find cgi-bin, even though it was 
exactly in the location the error logs said it was looking.  Here are the 
commands I ran, see if you can spot a step I missed, because I have to 
reschedule this and try again:

  752  mv /data01/home/rfelty2/rt3_backup-20110813.sql.gz /data02/rt3/
  753  cd /data02/rt3/
  754  gunzip rt3_backup-20110813.sql.gz
  755  mysql -h localhost -u root -p*PW-Redacted* rt3 < 
  757  vi /etc/my.cnf
  758  service mysqld restart
  759  mysql -h localhost -u root -p*PW-Redacted* rt3 < 
  760  cd /data02/rt3
  761  mysql -h localhost -u root -p*PW-Redacted* rt3 < 
  762  /data02/rt3/sbin/rt-setup-database --dba root 
--prompt-for-dba-password --action upgrade
  763  /data02/rt3/sbin/rt-setup-database --dba root -p*PW-Redacted* 
--action upgrade
  764  /data02/rt3/sbin/rt-setup-database --action schema --datadir etc 
--dba admin --prompt-for-dba-password
  765  /data02/rt3/sbin/rt-setup-database --action schema --datadir etc 
--dba root --prompt-for-dba-password
  766  /data02/rt3/sbin/rt-setup-database --action acl     --datadir 
etc/upgrade/2.1.0 --dba root --prompt-for-dba-password
  767  /data02/rt3/sbin/rt-setup-database --action insert     --datadir 
etc/upgrade/2.1.0 --dba root --prompt-for-dba-password
  768  /data02rt3/sbin/rt-setup-database --action schema     --datadir 
etc/upgrade/2.1.30 --dba root --prompt-for-dba-password
  769  /data02/rt3/sbin/rt-setup-database --action schema     --datadir 
etc/upgrade/2.1.30 --dba root --prompt-for-dba-password
  770  /data02/rt3/sbin/rt-setup-database --action acl     --datadir 
etc/upgrade/2.1.30 --dba root --prompt-for-dba-password
  771  /data02/rt3/sbin/rt-setup-database --action insert     --datadir 
etc/upgrade/2.1.30 --dba root --prompt-for-dba-password
  772  /data02/rt3/sbin/rt-setup-database --action schema     --datadir 
etc/upgrade/2.2.0RC2 --dba root --prompt-for-dba-password
  773  perl etc/upgrade/upgrade-mysql-schema.pl rt3 root *PW-Redacted* 
sql.queries mysql -u root -p rt3 < sql.queries
  774  perl etc/upgrade/upgrade-mysql-schema.pl
  775  perl ./etc/upgrade/upgrade-mysql-schema.pl
  777  cd /data02/rt3/local/plugins/RT-FM/etc/upgrade/
  778  perl ./upgrade-mysql-schema.pl
  779  perl ./upgrade-mysql-schema.pl rt3 root *PW-Redacted*
  780  perl ./upgrade-mysql-schema.pl rt3 root *PW-Redacted* > sql.queries
  782  service httpd restart
  783  vi /data02/rt3/etc/RT_SiteConfig.pm
  784  service httpd restart
  785  perl -c /data02/rt3/etc/RT_SiteConfig.pm
  798  cd /data02/RTFM-2.4.3/
  799  perl Makefile.PL
  800  make install
  804  /data02/rt3/sbin/rt-setup-database --action schema --datadir 
  806  /data02/rt3/sbin/rt-setup-database --action --dba root schema 
--datadir etc/upgrade/2.1.0
  807  /data02/rt3/sbin/rt-setup-database --action schema --dba root 
--datadir etc/upgrade/2.1.0
  808  /data02/rt3/sbin/rt-setup-database --action acl --dba root 
--datadir etc/upgrade/2.1.0
  809  /data02/rt3/sbin/rt-setup-database --action insert --dba root 
--datadir etc/upgrade/2.1.0
  812  /data02/rt3/sbin/rt-setup-database --action schema --dba root 
--dba-password *PW-Redacted* --datadir etc/upgrade/2.1.30
  813  /data02/rt3/sbin/rt-setup-database --action acl --dba root 
--dba-password *PW-Redacted* --datadir etc/upgrade/2.1.30
  814  /data02/rt3/sbin/rt-setup-database --action insert --dba root 
--dba-password *PW-Redacted* --datadir etc/upgrade/2.1.30
  816  /data02/rt3/sbin/rt-setup-database --action schema --dba root 
--dba-password *PW-Redacted* --datadir etc/upgrade/2.2.0RC2
  817  /data02/rt3/sbin/rt-setup-database --action acl --dba root 
--dba-password *PW-Redacted* --datadir etc/upgrade/2.2.0RC2
  818  /data02/rt3/sbin/rt-setup-database --action insert --dba root 
--dba-password *PW-Redacted* --datadir etc/upgrade/2.2.0RC2
  820  perl etc/upgrade/upgrade-mysql-schema.pl rt3 root *PW-Redacted* > 
  822  mysql -u root -p*PW-Redacted* rt3 < sql.queries
  825  rm -rf /opt/rt3/var/mason_data/*
  826  service httpd restart
  840  chmod 777 ticketlist
  875  /data02/rt3/sbin/rt-setup-database --dba root --dba-password 
*PW-Redacted* --action upgrade
  878  /data02/rt3/sbin/rt-setup-database --dba root --dba-password 
*PW-Redacted* --action upgrade
  886  /data02/rt3/sbin/rt-setup-database --dba root --dba-password 
*PW-Redacted* --action upgrade
  892  rm -fr /opt/rt3/var/mason_data/obj
  893  service httpd restart
  898  tar -cvf www.tar www
  899  mv www.tar /data02/rt3/share/html/
  901  tar -xvf www.tar
  911  vi RT_SiteConfig.pm
  912  tail -500 /data02/rt3/var/log
  915  tail -500 rt.log
  919  mv /data02/rt3/share/html/www.tar .
  920  tar -xvf www.tar
  921  tail -500 ../logs/rt.log
  922  tail -500 /data02/rt3/var/log/rt.log

Cgi-bin errors from error log:

[root at s601445dc4vl150:~] cat /usr/local/httpd/logs/error_log|grep -i 

[Sat Aug 13 10:17:49 2011] [warning]: [Mason] Cannot resolve file to 
component: /data02/var/www/cgi-bin/sla_report (is file outside component 
root?) at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 
852, <DATA> line 1662. 
[root at s601445dc4vl150:~] ls /data02/var/www/cgi-bin/sl*
-rwxr-xr-x 1 root root 3268 Oct 17  2008 
-rwxr-xr-x 1 root root 5461 Oct 21  2008 
-rwxrwxrwx 1 root root 5460 Oct 21  2008 

[root at s601445dc4vl150:~] vi 
 852         warn "[Mason] Cannot resolve file to component: " .


Rezty Felty
Hallmark Digital - Infrastructure

MSN rustyfelty at hotmail.com
ICQ 1932818
Skype Rezty.Felty
Googletalk Rezty at KC-Felty.Net 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20110817/64a5f115/attachment.htm>

More information about the rt-users mailing list