[rt-users] Problem with database upgrade - PostgreSQL, RT 3.8.9 -> 4.0.0

Kevin Falcone falcone at bestpractical.com
Sun May 1 19:16:56 EDT 2011

On Sun, May 01, 2011 at 07:56:02PM +0200, hubert depesz lubaczewski wrote:
> First of all - there is error in the migration, as it tries to update value using bad datatype.

Someone else flagged this on Friday, it'll be fixed in 4.0.1, there is
some discussion in the list archives.

> Second - why some tables are created, and lest as owned by "postgres",
> and their ownership is not changed to standard user? Should I ran it
> differently?

That sounds like it could be a bug that needs resolving in 4.0.1 also

> But the rtfm thing worries me actually more - as far as I know, I never had
> rtfm in this system - I am not 100% sure because I took over administration of
> this from someone, and now I'm on my own, but the web interface doesn't
> show anything related to rtfm.

That is a false positive, you can ignore it, however the earlier error
in the migration means that if you tried to test this install, your
linked Custom Fields won't work quite right.

We'll be announcing RT 4.0.1rc1 sometime next week on the rt-devel
mailing list once we've sorted out a few things.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20110501/d36edce4/attachment.sig>

More information about the rt-users mailing list