[rt-users] ExternalAuth, local users, and upgrade woes

Yan Seiner yan at seiner.com
Tue Nov 8 10:27:34 EST 2011

Yesterday we upgraded our RT instance to 4.0.2.  Before then we were
running 3.8.10 in production, and 4.0.2 in testing.

We had 4.0.2 set up in testing with ExternalAuth.  That worked well; our
LDAP users could log in with their credentials.  I could create non-LDAP
users manually (which is the setup I wanted).

Then we moved the database from the server hosting 3.8.10 to our new 4.0.2
server.  Everything went well, except that non-LDAP users cannot log in. 
Further, I cannot change their password.

When I try to change their password, I get

Please enter your current password correctly. Password has not been set.

I tried creating a user manually.  Same thing; I can create the user but
cannot set the password.

This worked fine in the 4.0.2 test but started happening after we moved
the 3.8.10 database over to 4.0.2.  I did use the procedures in the README
and otherwise the new installation is working great.

Where do I look?

Pain is temporary. It may last a minute, or an hour, or a day, or a year,
but eventually it will subside and something else will take its place. If
I quit, however, it lasts forever.

More information about the rt-users mailing list