[rt-users] RT 4.0.3 upgrade problem

Jeff Sampson ffercs at gmail.com
Wed Nov 9 17:17:20 EST 2011

Hi All,
I just updated my previously working 4.0.2 RT server to 4.0.3.  RT is
running under mod_perl on this box.  I followed all of the upgrade
instructions as usual (./configure;make testdeps;make upgrade;make
upgrade-database, and cleared the mason cache directory).  The problem is
that when visiting the RT URL server gives a HTTP 500 error.  In syslog I
get these messages.

Nov  9 11:43:22 noname RT: Subroutine handle_startup_error redefined at
/opt/rt4/sbin/rt-server line 238. (/opt/rt4/sbin/rt-server:238)
Nov  9 11:43:22 noname RT: Subroutine handle_bind_error redefined at
/opt/rt4/sbin/rt-server line 250. (/opt/rt4/sbin/rt-server:250)
Nov  9 11:43:34 noname RT: #011(in cleanup) Error while loading
/opt/rt4/sbin/rt-server: Can't locate object method "ComponentRoots" via
package "RT::Interface::Web" at /opt/rt4/sbin/../lib/RT/
Config.pm line 205. (/opt/rt4/sbin/../lib/RT.pm:343)

Here is what I have tried:
-Make sure my perl dependencies are all up to date.  I did this using
CPAN.  A make testdeps shows everything to be in order.
-Tried disabling external plugins.  I am using RT-Authen-ExternalAuth with
an LDAP backend.  No change here.
-Restoring a backup copy of /opt/rt4 version 4.0.2.  I didn't revert the
database, but it still gives the same error so I don't think it's database.

Any ideas on what to do next would be greatly appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20111109/4080f69a/attachment.htm>

More information about the rt-users mailing list