[rt-users] Apache2.2 won't start at boot. RT4.0.4 on debian 6

20/20 Lab lab at pacbell.net
Fri Jan 13 11:13:29 EST 2012

What does your default site conf look like?   Are there server specific 
settings there that might be causing the trip up?  Have you tried 
enabling both?  Have you tried changing the boot order(?)?  Try setting 
the LogLevel to debug (apache2.conf/httpd.conf), then restarting your 
server and see if something appears in the logs about it.  I'm not 
familiar with a2ensite/a2dissite so that may be the issue.  If it 
assumes that once you disable the default site that you wont be using 
apache, it may be removing the appropriate link in your rc3.d / rc5.d 
directory.  After you enable the rt site, and disable the default, do 
you have any links in those directories?

I'm not on a debian machine, so I'm not horribly familiar with the 
specific distro layout.


On 01/12/2012 9:45 AM, Glenn McNeill wrote:
> Hi,
> I'm having a major headache trying to get apache2 (for a clean install
> of RT4.0.4, on a clean install of Debian 6.0.3)  to start at boot.
> If I leave the default apache site enabled, with no RT site in the
> config, then apache will start at boot with no problem. If I enable
> the RT site and disable the default one then apache will not start at
> boot.
> However there is absolutely nothing in **any** log file to suggest
> that apache has even attempted to start, let alone why it has not
> started.
> I can start apache manually by running "/etc/init.d/apache2 start"
> which works perfectly.
> I've followed the RT4 install readme to the letter and I've gone
> through the whole process from scratch (and I mean installing debian
> from scratch) at least 4 times now and it's getting frustrating to say
> the least.
> My RT site apache conf is as follows, and is only different from the
> default as suggested in web_deployment.pod in that my "VirtualHost"
> has been changed to my own:
> <VirtualHost rtir.abuse>
>       ### Optional apache logs for RT
>       ErrorLog /opt/rt4/var/log/apache2.error
>       TransferLog /opt/rt4/var/log/apache2.access
>       LogLevel debug
>       AddDefaultCharset UTF-8
>       DocumentRoot "/opt/rt4/share/html"
>       <Location />
>            Order allow,deny
>            Allow from all
>            SetHandler modperl
>            PerlResponseHandler Plack::Handler::Apache2
>            PerlSetVar psgi_app /opt/rt4/sbin/rt-server
>       </Location>
>       <Perl>
>            use Plack::Handler::Apache2;
>            Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");
>       </Perl>
> </VirtualHost>
> I use the commands a2ensite&  a2dissite to enable/disable both the
> default apache site and my RT site
> There doesn't seem to be any other reports from anyone else having
> this issue so what the hell is going on, and how do I fix it?!
> Cheers,
> Glenn
> --------
> RT Training Sessions (http://bestpractical.com/services/training.html)
> * Boston  March 5&  6, 2012

More information about the rt-users mailing list