[rt-users] RT 4.08 Account creation

John Johnston johnj at msu.edu
Wed Nov 21 13:24:11 EST 2012


I've installed RT 4.0.8 on a RHEL 6.2 system and overall it's working 
fine with one notable exception.  We authenticate users with Shibboleth, 
and once so authenticated they are able to create tickets.  First time 
users have their accounts auto-created.  We had a previous instance of 
RT 3.0.7 and used perl-based forms for ticket creation.  Auto-creation 
of accounts worked fine, with the displayname, email, and userid 
returned from Shibboleth and passed to RT.  However, these same forms 
when used on RT 4.0.8 while they *do* create the account if it doesn't 
exist, and it does set the "Name" to the email address, the 
"EmailAddress" itself and "RealName" are left blank.

This means that users cannot get email on their tickets (confirmatory or 
otherwise), unless an administrator goes in, selects the account, and 
manually adds the email address.  I've tried several workarounds, 
including doing a mysql query to see if the account exists, and if not, 
to create it using an RT CLI command encased in backticks.  This is 
contained in our "contact" ticket creation form.  I've experimented with 
several options, including escaping the "@" in the email address.  
Recently, I used Encode to ensure the values obtained from Shibboleth 
were converted into UTF-8 before being passed to the RT CLI command, and 
this *sort of* worked.  Interestingly, it added the account but dropped 
the letter "e" from the mymail.edu address (to leave mymail.du).  Also 
interesting, is if I bypass the Shibboleth values and hard code in an 
email address like:

my $clean_email = "skippy at mailme.edu"

And pass it to the RT CLI command like:

$result = `/opt/rt4/bin/rt create -t user add Name=$your_netid 
EmailAddress=$clean_email `;

...again, it works fine.

I've been banging my head on this for awhile.  Any insights would be 


On 11/21/2012 1:03 PM, Guy Baxter wrote:
> Hi,
> I've installed 4.0.8 on CentOS 6.3, satisfied all dependencies etc, 
> run the web installer to get things started, but I can't actually get 
> my RT pages to load. I've tried using all of the apache options on 
> web_deployment on the installation pages at bestpractical.com 
> <http://bestpractical.com/> but with no luck.
> using mod_fcgi and mod_fcgid I get 404 not found, with a corresponding 
> log entry in /var/log/httpd/error.log of:
> File does not exist: /opt/rt4/sbin/rt-server.fcgi
> The file does exist, and won't start manually even when invoked from 
> sbin with ./
> Trying the mod_perl apache setup results in Apache failing to start:
> Undefined subroutine &main::. called. END failed-- call queue aborted. 
> (/opt/rt4/sbin/../lib/RT.pm:341)
> Any ideas - this has got me totally stuck!
> Thanks in advance.
> --------
> We're hiring! http://bestpractical.com/jobs

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20121121/88378764/attachment.htm>

More information about the rt-users mailing list