[rt-users] ExternalAuth problems

Jeff Solberg jsolberg at intrepidls.com
Thu Aug 1 12:21:55 EDT 2013

When you removed the extra '(' did you also remove the extra ')' from the end of the declaration? Your plug in line should look like this

Set(@Plugins, qw(RT::Extension::CommandByMail RT::Authen::ExternalAuth));

Restart Apache..

If this doesn’t work go into RT as root then go into the system configuration

Tools--> Configuration --> tools--> System Configuration

And see if the plugs are being set. Hope this helps.


-----Original Message-----
From: rt-users-bounces at lists.bestpractical.com [mailto:rt-users-bounces at lists.bestpractical.com] On Behalf Of Brian Haupt
Sent: Thursday, August 01, 2013 9:06 AM
To: rt-users at lists.bestpractical.com
Subject: Re: [rt-users] ExternalAuth problems

I have tried removing the extra '(' as recommended but with no success. I have also tried using changing
'user'                      =>  $AD_User@$InternalNetwork ', to
'user'                      =>  'cn=$Username,cn=Users,dc=internal,dc=$DomainName,dc=com',

I also tried adding 
Set($LdapServer, 'ldaps://myDomainController.xxxxxxx.com');
Set($LdapTLS, 1);
Set($LdapSSLVersion, 3);

But none of these have yielded any better results.

-----Original Message-----
From: Jeff Solberg [mailto:jsolberg at intrepidls.com] 
Sent: Thursday, August 01, 2013 11:23 AM
To: Brian Haupt; rt-users at lists.bestpractical.com
Subject: RE: [rt-users] ExternalAuth problems

Try removing the extra '(' you have in front of qw in your set at plugin declaration.


From my Android phone on T-Mobile. The first nationwide 4G network.

-------- Original message --------
From: Brian Haupt <brian.s.haupt at ama-inc.com>
Date: 08/01/2013 7:48 AM (GMT-08:00)
To: rt-users at lists.bestpractical.com
Subject: [rt-users] ExternalAuth problems

I am setting up a new Request Tracker 4.0.16 installation on CentOS 6.4. I  am able to log into RT using the RT root password but I receive the following error when trying to login using my AD account

[Thu Aug  1 14:37:33 2013] [error]: FAILED LOGIN for $UserName from $IP_Address (/usr/local/rt/sbin/../lib/RT/Interface/Web.pm:753)

Below is the relavent part of my RT_SiteConfig

Set($WebPort, 443);
Set($WebPath, "/rt");
Set($WebDomain, '$hostname.$PublicDomain'); Set($rtname, '$hostname');

Set($ExternalSettings, {
        'My_LDAP'       =>  {
            'type'                      =>  'ldap',

            'server'                    =>  '$DC.$InternalNetwork',
            'user'                      =>  '$AD_User@$InternalNetwork',
            'pass'                      =>  '$Password',

            'base'                      =>  'dc=$InternalNetwork',
            'filter'                    =>  '(objectClass=*)',
            'attr_map' => {
                'Name' => 'displayName',
                'EmailAddress' => 'mail',
                'RealName' => 'cn',
                'ExternalAuthId' => 'sAMAccountName',
                'Gecos' => 'sAMAccountName',

# You must install Plugins on your own, this is only an example # of the correct syntax to use when activating them.
# There should only be one @Plugins declaration in your config file.
Set(@MailPlugins, qw(Auth::MailFrom Filter::TakeAction)); Set(@Plugins,(qw(RT::Extension::CommandByMail RT::Authen::ExternalAuth)));


More information about the rt-users mailing list