[rt-users] Scripting ticket creation with fields containing non-alphanumeric characters.

Kevin Falcone falcone at bestpractical.com
Mon Aug 5 11:11:08 EDT 2013

On Mon, Aug 05, 2013 at 01:27:33PM +0000, Green, Jesse wrote:
>    I'm very new to RT and am trying to write a python script to create a ticket in my RT
>    database.  The crux of my problem lies in non-alphanumeric characters.  Submitting the ticket
>    works fine with all the fields that have only alphanumeric characters, but I have some fields
>    with non-alphanumeric characters and those submissions return to me "Error 409 Syntax Error".
>    I am using python-rtkit to work with REST from my script.  To try and solve this problem I
>    have corresponded with the person who maintains python-rtkit to make sure that it wasn't a bug
>    in python-rtkit or my misuse of the module ([1]https://github.com/z4r/python-rtkit/issues/31 ,
>    you can find a copy of my script in this thread for reference).  The conclusion reached at the
>    end of that discussion was that I would need to upgrade my install of RT from its current
>    version of 3.6.6 to 4.x.  However  I have discovered from my superior (who is in charge of our
>    install of RT) that that isn't an option.
>    After I tried that I tried to poke around and find some documentation on Error 409 but was
>    unable to find any documentation of RT's errors anywhere but WAS able to find a
>    correspondence for a similar issue
>    ([2]http://www.gossamer-threads.com/lists/rt/users/95179?search_string=REST%20syntax;#95179)
>    unfortunately it is for a different version of RT (3.8.x) and the suggested fix involved a
>    line in REST.pm that doesn't exist in my install of RT.  Which brings me to posting in this
>    mailing list.
>    I'm wondering if there's a fix similar to the other one posted in the mailing list (see second
>    link in this post) for RT3.6.6 that I can use to enable the creation of tickets via an
>    external script without having to upgrade RT or remove those special characters

3.6.6 is more than 5 years old and has actually been End of
Lifed for nearly 2 years now:
You may want to talk to your supervisor again.  There are a number of
security issues in that release.

The code you're running into was refactored before 3.8.0 was released,
so any patch that was later applied to 3.8 or 4.0 to fix problems with
the Custom Field parsing will be annoying to backport.  As a result, I
cannot just point you to a commit in git and tell you to apply it,
someone would have to develop and backport a branch.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 235 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20130805/1a9d9e0b/attachment.sig>

More information about the rt-users mailing list