[rt-users] Having trouble upgrading: Unknown column 'm.LastUpdatedBy' in 'on clause' at /usr/sbin/rt-validator

Alex Vandiver alexmv at bestpractical.com
Mon Dec 2 11:45:24 EST 2013

On Mon, 2013-12-02 at 11:38 +0100, ms at fv-berlin.de wrote:
> Hi,
> I'm trying to upgrade a 3.6.1-4 (don't ask) RT to 4.0.4-2 and I ran into
> issues.
> First of all: I am doing this upgrade (test) on a duplicate of the
> actual production system, so no worries.
> As part of the preparation before running the actual database upgrade, I ran
> rt-validator --check

RT 3.6.1 didn't ship an rt-validator -- it appeared in 3.8.  Because the
schemas are different, you cannot simply run a current rt-validator
against the 3.6 schema, either.

> At least that's how I explained the following error, that occurs when
> running the actual database upgrade afterwards:

This is orthogonal.

> [...]
> Processing 3.7.81
> Now populating database schema.
> [crit]: DBD::mysql::st execute failed: Duplicate key name
> 'CachedGroupMembers3' at /usr/share/request-tracker4/lib/RT/Handle.pm
> line 515. (/usr/share/request-tracker4/lib/RT.pm:351)
> DBD::mysql::st execute failed: Duplicate key name 'CachedGroupMembers3'
> at /usr/share/request-tracker4/lib/RT/Handle.pm line 515.

The 3.6 -> 3.8 upgrade steps attempt to create an index named
'CachedGroupMembers3', which you appear to already have added by hand
locally.  If you run 'DROP INDEX CachedGroupMembers3' the upgrade steps
should run correctly.
 - Alex

More information about the rt-users mailing list