[rt-users] Rt search does not work with sphinx main+delta index

Guadagnino Cristiano guadagnino.cristiano at creval.it
Wed Sep 11 03:07:50 EDT 2013


Well, it turned out that the problem with 4.0.17 not returning any result was due to a stale searchd process.
Restarting the daemon reverted behavior to that of RT 4.0.10, which was anyway wrong.

So, to restate it clearly: RT is only returning results from the main index, completely ignoring the delta index.

Please help.

Bye
Cris


Guadagnino Cristiano wrote:
I am having trouble with RT fulltext searches. I am using RT 4.0.17 with Mysql and Sphinx 4.0.8.
Sphinx is configured to use a main+delta index (configuration attached). Main index is created once every morning, while the delta index is created every 5 minutes.
If I search using the "search" command line tool from Sphinx everything is correct.

Fulltext search with RT 4.0.10 instead seemed to return only the results from the main index, disregarding anything from the delta index.
So I updated to the latest RT release (4.0.17) just to be sure. Now fulltext search with RT does not return anything at all!!

Example from the CLI:

search CrevalPublic --rsort=date -q -l 500

This returns 73 hits on the main index and 39 ihits on the delta index.

Simple search with RT:

fulltext:CrevalPublic any

This returns 0 results.

Any suggestions?

T.I.A.
Bye
Cris
--
Cristiano Guadagnino
Servizio Data Administration
Bankadati S.I.
Gruppo Credito Valtellinese


--
Cristiano Guadagnino
Servizio Data Administration
Bankadati S.I.
Gruppo Credito Valtellinese


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20130911/c20707e7/attachment.html>


More information about the rt-users mailing list