[rt-users] Fedora 20 / Perl 5.18

Kevin Falcone falcone at bestpractical.com
Tue Feb 18 14:16:54 EST 2014


On Tue, Feb 18, 2014 at 11:08:45AM -0800, CLOSE Dave wrote:
> > The most common type of error is the wrong version of mdo_perl
> 
> Both perl and mod_perl come from Fedora packages and both are the same 
> version. If that were my problem, everyone using F20 and perl would be 
> complaining.

Since you failed to indicate your deployment method in your original
email, you forced us to guess and grasp at straws.

> >> CORE missing dependencies:
> >>           Data::GUID ...MISSING
> >>                   Perl API version v5.16.0 of v does not match v5.18.0 at
> >> /usr/lib64/perl5/DynaLoader.pm line 213.
> >>
> >> But the perl-Data-GUID package is /not/ missing.
> >>
> >> # ls -l /usr/share/perl5/vendor_perl/Data/GUID.pm
> >> -rw-r--r-- 1 root root 8799 2013-12-13 05:23
> >> /usr/share/perl5/vendor_perl/Data/GUID.pm
> 
> > Those are two different paths.
> 
> Of course, they are. One is the program which detected the error, the 
> other is the file about which it is complaining. But what the heck is "v"?

Which one is a program, they both look like perl modules to me
/usr/lib64/perl5/DynaLoader.pm
/usr/share/perl5/vendor_perl/Data/GUID.pm

> > Ensure that when you're in the upgrade directory you have perl-5.18 in
> > your path before perl-5.16 before running configure.
> >
> > You appear to have a few perls and differing 32bit vs 64bit problems.
> 
> I have only one perl installed and no relevant 32-bit packages. Why do 
> you think otherwise?

Because one is installed in /usr/share/perl5 the standard RH perl
library path for site_lib.  The other is installed in a specific lib64
path and is *clearly* a leftover from a 5.16 install (or is detecting
in your @INC something left over from 5.16).

When you upgraded this box and perl was upgraded, did the RPM clean
out the old site installed modules because of binary incompatibility?

I'll repeat my advice:

> > Ensure that when you're in the upgrade directory you have perl-5.18 in
> > your path before perl-5.16 before running configure.

If it's still failing after you re run configure with perl-5.18 in
your path, please show a full error,  Then show us perl -V.
A full error includes attempting to *install* Data::GUID, not merely
RT telling you that it isn't installed.

-kevin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 235 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20140218/df72c4c8/attachment.pgp>


More information about the rt-users mailing list