[rt-users] REST call to retrieve list of groups

Guadagnino Cristiano guadagnino.cristiano at creval.it
Thu Feb 20 10:20:38 EST 2014

Hi Kevin

Kevin Falcone ha scritto:
> On Tue, Feb 18, 2014 at 02:58:29PM +0000, Guadagnino Cristiano wrote:
>> I'm sorry to bump this thread, but I never had any feedback, neither
>> positive nor negative.
>> Is this something supposed to work in 4.2.2 or not?
>>>>            rt ls -t groups
> When someone shows a bin/rt command that works, you can always see
> what it is doing by re-running it locally and adding
> RTDEBUG=3 to the shell environment (or debug 3 to your rtrc).
> The error will become clear once you do that.
> -kevin

Kevin, thank you for the bit about using RTDEBUG, this is very useful!!

I tried that from the command line and from the output I see it is 
POSTing to http://localhost//REST/1.0/search/group. All the groups are 
correctly reported.

So it seems my problem was just that I was writing "groups" in stead of 
"group" in the URL.
However, when I try this from the browser (Firefox) I still get the same 
error as before:

no value sent for required parameter 'query'

There must still be something that's escaping me.

This could be greatly improved if there was some kind of documentation 
on the REST protocol as implemented by RT, besides the largely 
incomplete one that is on WIKIA.
Without that, the only way is discovering it by trial and error.


More information about the rt-users mailing list